Créer une feuille de calcul a partir d'autre avec macros

TSniper

XLDnaute Nouveau
Bonjour,
J'ai un classeur qui contient les informatios sur un projet.
Chaque employé passe un certains temps à travayer dessus dans des dates différentes en collaborations avec tout le groupe.
je veux créer une nouvelle feuille qui calcul le temps total du travail d'un employer dans tout les projet.
tout ça avec un macro
je suis la pour plus d'explications
Merci
 

Fichiers joints

Dernière édition:

tototiti2008

XLDnaute Barbatruc
Re : Créer une feuille de calcul a partir d'autre avec macros

Bonjour TSniper,

Bienvenue sur XLD,

peut-être, en D8 de la feuille Total

Code:
=SOMME.SI(Feuil1!$B$31:$B$39;Total!C8;Feuil1!$E$31:$E$39)+SOMME.SI(Feuil2!$B$31:$B$39;Total!C8;Feuil2!$E$31:$E$39)+SOMME.SI(Feuil3!$B$31:$B$39;Total!C8;Feuil3!$E$31:$E$39)
Edit : Oups, j'avais pas lu "avec macros"...
 
Dernière édition:

TSniper

XLDnaute Nouveau
Re : Créer une feuille de calcul a partir d'autre avec macros

Quelqu'un a des idées ?
Merci
 
G

Guest

Guest
Re : Créer une feuille de calcul a partir d'autre avec macros

Bonjour,

Un petit merci pour tototiti, même s'il n'a pas vu "avec macro", pour l'effort le temps passé.

A+
 

TSniper

XLDnaute Nouveau
Re : Créer une feuille de calcul a partir d'autre avec macros

Bonjour TSniper,

Bienvenue sur XLD,

peut-être, en D8 de la feuille Total

Code:
=SOMME.SI(Feuil1!$B$31:$B$39;Total!C8;Feuil1!$E$31:$E$39)+SOMME.SI(Feuil2!$B$31:$B$39;Total!C8;Feuil2!$E$31:$E$39)+SOMME.SI(Feuil3!$B$31:$B$39;Total!C8;Feuil3!$E$31:$E$39)
Edit : Oups, j'avais pas lu "avec macros"...
Merci commemêm pour l'effort j'espère que je trouve d'autres idée pour ce MACRO
 

TSniper

XLDnaute Nouveau
Re : Créer une feuille de calcul a partir d'autre avec macros

Bonjour,

Un petit merci pour tototiti, même s'il n'a pas vu "avec macro", pour l'effort le temps passé.

A+
oui Biensur il a fait ce qu'il peut pour m'aider MERCIIIIIIIIIIIIIIIIIII tototiti
 

TSniper

XLDnaute Nouveau
Re : Créer une feuille de calcul a partir d'autre avec macros

Je veut remrcier tous le monde et qui va me donner une réponse
 

tototiti2008

XLDnaute Barbatruc
Re : Créer une feuille de calcul a partir d'autre avec macros

Bonjour TSniper,

Edit : Oups, Erreur, désolé

Je regarde ça et je te reviens
 

tototiti2008

XLDnaute Barbatruc
Re : Créer une feuille de calcul a partir d'autre avec macros

Re,

un essai

Code:
Option Explicit

Sub CalcTotal()
Dim i As Long, j As Long, k As Long, Dico, Somme() As Double, Elt As Variant
    Set Dico = CreateObject("Scripting.Dictionary")
    ReDim Somme(1 To 1)
    With Sheets("Total")
        .Range("C8:D65536").ClearContents
        For i = 1 To 3 'Feuilles Feuil1 à Feuil3
            j = 31 'Ligne de début des données sur chaque feuille
            Do Until Sheets("Feuil" & i).Cells(j, 2).Value = ""
                Dico(Sheets("Feuil" & i).Cells(j, 2).Value) = 1
                If Dico.Count > UBound(Somme) Then
                    ReDim Preserve Somme(1 To UBound(Somme) + 1)
                    Somme(UBound(Somme)) = CDbl(Sheets("Feuil" & i).Cells(j, 5).Value)
                Else
                    Elt = Dico.keys
                    For k = LBound(Elt) To UBound(Elt)
                        If Elt(k) = Sheets("Feuil" & i).Cells(j, 2).Value Then
                            Somme(k + 1) = Somme(k + 1) + CDbl(Sheets("Feuil" & i).Cells(j, 5).Value)
                            Exit For
                        End If
                    Next k
                End If
                j = j + 1
            Loop
        Next i
        'Ecriture résultats
        Elt = Dico.keys
        For i = LBound(Elt) To UBound(Elt)
            .Range("C" & i + 8).Value = Elt(i)
            .Range("D" & i + 8).Value = Somme(i + 1)
        Next i
    End With
End Sub
 

TSniper

XLDnaute Nouveau
Re : Créer une feuille de calcul a partir d'autre avec macros

Merci beaucoup totitoti :) je vais essayer ça et je te tien au courant
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas