création d'un barème qui combine deux recherches conditionnelles différentes

Grimpeur65

XLDnaute Nouveau
Bonjour à tous.
Je me présente : Fabrice, prof d'EPS dans le Sud-Ouest qui essaie de se mettre à Excel (vieux motard que j'avais !)
Voila mon problème : j'essaie de créer une feuille de calcul qui me permette de donner rapidement à mes élèves une note en escalade.
L'épreuve est constituée de deux sous-épreuves : une "voie", côtée de 0 à 5C, puis, AU CHOIX d'une deuxième "voie" OU d'une épreuve de "bloc" cotée par des lettres correspondant à des couleurs (TP, V, J, B, R)
J'ai utilisé en colonne I et J l'outil de validation des données ET la fonction INDIRECT puisque je voulais que les items apparaissant en J soient dépendantes de celle choisie en I.
Mon problème est en colonne K, qui doit me donner automatiquement, en se référant aux barêmes de la deuxième feuille, la valeur de la voie OU du bloc choisi par l'élève. Cela fonctionne très bien pour le barème des voies mais pas pour le barème des blocs qui me renvoie en K des valeurs erronées.
Est-ce que quelqu'un pourrait me donner une piste de recherche ou une solution ?
Merci !
 

Fichiers joints

sousou

XLDnaute Accro
Bonsoir
exemple ligne 5:
C'est un bloc, tu cherche j5 (5c) dans la plage des bloc! elle n'existe pas
Pour les bloc la cotation ne peux être 5c
 

Grimpeur65

XLDnaute Nouveau
Bonsoir Sousou,
Bon déjà, merci de t'intéresser à mon cas. Je comprends ce que tu me dis, mais restons sur la ligne 2 si ça ne t'ennuie pas, pour simplifier.
Si je choisis "bloc" en I2, puis "V" en I3, ce devrait être la valeur "1,75" qui apparait en K2 (en référence au barème qui va de F6 à G10 sur la feuille "barèmes" ; or dans ce cas, c'est la valeur "4" qui est renvoyée et qui apparait en K2.
Est-ce que tu comprends pourquoi stp ?
 

sousou

XLDnaute Accro
re
ta formule serait plutôt celle-ci (pour la ligne 2)
=SI(I2="bloc"; RECHERCHEV(J2; barèmes!$F$6:$G$10;2;FAUX); RECHERCHEV(Evaluation!J2; barèmes!$B$6:$C$12;2;FAUX))
 

Grimpeur65

XLDnaute Nouveau
Merci Sousou, ça marche !
Quelques questions stp :
1) pourquoi RECHERCHEV et pas RECHERCHE ?
2) A quoi sert dans la formule ";2;FAUX"
3) accessoirement, peux-tu m'expliquer mon erreur stp ?

Encore merci, cdlmt
 

sousou

XLDnaute Accro
La recherchev permet de sélectionner la colonne de la matrice qui va renvoyer la réponse(ici:2)
pour le faux je te conseil de bien lire l'aide de cette fonction, et de faire des essais pour voir la différence
Tu verras que cette fonction est très prisée des spécialistes des formules
 

Discussions similaires


Haut Bas