XL 2019 Copier certains éléments d'un tableau vers un autre tableau

jrmy34

XLDnaute Nouveau
Bonjour,

Je bloc depuis, oulalala au moins une semaine !!!!!

J'ai un tableau avec des éléments mélanger dans la première colonne. Je souhaite créer un second tableau avec uniquement les lignes qui corresponde à "test".

Il est important que les lignes se collent, qu'il n'y ait pas de ligne vide entre.

Je vous ai fait un fichier avec à gauche le tableau brut, au milieu ce que j'ai commencé à coder...sans résultat suffisant (redondance que je souhaiterai supprimer), et le tableau de droit qui serait le résultat final, désiré.

Le document de base est un google sheet ... Il ne faut donc pas de code vba ...

Un grand merci à vous.
 

Pièces jointes

  • Test-tableau.xlsx
    11.1 KB · Affichages: 4

mapomme

XLDnaute Barbatruc
Supporter XLD
Bonsoir @jrmy34 ;),

Voir formule matricielle en G4 à copier vers la droite et vers le bas:
VB:
=SIERREUR(INDEX(B:B;PETITE.VALEUR(SI($B$4:$B$9="test";LIGNE($B$4:$B$9);"");LIGNES($1:1)));"")

1637880500029.png
 

Pièces jointes

  • jrmy34- Test-tableau- v1.xlsx
    11.2 KB · Affichages: 3

Discussions similaires

Statistiques des forums

Discussions
292 811
Messages
1 926 469
Membres
183 093
dernier inscrit
Juvenat