XL 2019 Conditions sur une plage de cellule

anouarlachiri

XLDnaute Occasionnel
Supporter XLD
Bonjour,

J'espère que vous allez bien :)

Je souhaite effectuer le traitement suivant dans Excel (sans passer en VBA) :

- j'ai des valeurs dans la plage I4:I9
- je souhaite savoir pour chacune des valeurs de cette plage si elle se trouve dans la plage F18:F24.
- Si la valeur existe alors je veux que je souhaite de deviser les deux valeurs correspondant ( colonne J /Colonne M ) dans le tableau en colonne P

Ci joint une exemple
Merci pour votre aide :)
 

Pièces jointes

  • test1.xlsx
    11.1 KB · Affichages: 7
Solution
Bonjour,

VB:
=J4/INDEX($M$18:$M$24;EQUIV(I4;$F$18:$F$24;0))
ou
Code:
=SIERREUR(J4/INDEX($M$18:$M$24;EQUIV(I4;$F$18:$F$24;0));"")
selon ce que tu veux si non trouvé.

Mais un nombre (CA) tu es sûr que c'est suffisant pour déterminer une ligne ? Si doublon, c'est mort...
eric

eriiic

XLDnaute Barbatruc
Bonjour,

VB:
=J4/INDEX($M$18:$M$24;EQUIV(I4;$F$18:$F$24;0))
ou
Code:
=SIERREUR(J4/INDEX($M$18:$M$24;EQUIV(I4;$F$18:$F$24;0));"")
selon ce que tu veux si non trouvé.

Mais un nombre (CA) tu es sûr que c'est suffisant pour déterminer une ligne ? Si doublon, c'est mort...
eric
 

Discussions similaires

Réponses
2
Affichages
244
Réponses
7
Affichages
328
Haut Bas