XL 2013 condition

chinel

XLDnaute Occasionnel
Bonjour tout le monde ! petit question avec la fonction "si"
j'ai une colonne et je doit mettre dedans des horaires.
exemple:
si le mardi 1 janvier 2019 je mets 14h00-22h00 (en 2019 la première semaine de janvier compte que 4 jours)
automatiquement la semaine d'après se note en 06h00-14h00
et la semaine encore d'après se note en 22h00-06h00
ainsi de suite jusqu'au 31 décembre sachant qu'il n'y a que 3 pauses et 5 jours de travail (du lundi au vendredi inclus)


Merci
 

Modeste geedee

XLDnaute Barbatruc
Bonjour tout le monde ! petit question avec la fonction "si"
j'ai une colonne et je doit mettre dedans des horaires.
exemple:
si le mardi 1 janvier 2019 je mets 14h00-22h00 (en 2019 la première semaine de janvier compte que 4 jours)
automatiquement la semaine d'après se note en 06h00-14h00
et la semaine encore d'après se note en 22h00-06h00
ainsi de suite jusqu'au 31 décembre sachant qu'il n'y a que 3 pauses et 5 jours de travail (du lundi au vendredi inclus)


Merci
pour résumer :
j'ai pas de scie :confused:
j'ai beaucoup de colonnes...:rolleyes:
3 horaires sont possibles par roulement

travailler avec la Fonction N°_SEMAINE et la fonction MOD
=CHOISIR(1+MOD(N°_semaine(ladate) ; 3 ) ;{"14h-22h";"6h-14h";"22h-06h"})
 

job75

XLDnaute Barbatruc
Bonjour chinel, Modeste geedee, le forum,

Pas compris les "3 pauses" mais avec les dates de l'année en colonne A mettre en B1 :
Code:
=SI(JOURSEM(A1;2)>5;"";CHOISIR(1+MOD(NO.SEMAINE(A1)-1;3);"14h00-22h00";"06h00-14h00";"22h00-06h00"))
A+
 

Modeste geedee

XLDnaute Barbatruc
Re,

C'est donc bien ce qu'on avait compris, ma formule du poste #3 s'applique parfaitement, fichier joint.

PS : en français "pause" est l'arrêt d'une activité :

https://www.larousse.fr/dictionnaires/francais/pause/58775

A+
upload_2018-12-3_13-35-22.png upload_2018-12-3_13-36-34.png
:cool: petite modification pour s'affranchir de la fonction NO_semaine qui donne souvent 2 n° de semaines différents pour la semaine à cheval sur le changement d'année
=SI(JOURSEM(A1;2)>5;"";CHOISIR(1+MOD(ENT(A1-2)/7;3);"06h00-14h00";"22h00-06h00";"14h00-22h00"))
upload_2018-12-3_13-38-52.png
 

job75

XLDnaute Barbatruc
chinel a parlé des dates du 1er janvier au 31 décembre, dans ce cas la fonction NO.SEMAINE va bien.
 

job75

XLDnaute Barbatruc
Re,
:p rendez-vous donc en fin d'année 2019 pour élaboration du planning 2020...
;):cool:
Oui mais si l'on veut un planning sur plusieurs années entrer en B1:B21 les horaires du 1er janvier 2019 au 21 janvier2019 (3 semaines complètes).

Puis entrer en B22 cette formule à tirer vers le bas =""&B1

Fichier (2).

A+
 

Fichiers joints

Discussions similaires


Haut Bas