1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

XL 2013 condition

Discussion dans 'Forum Excel' démarrée par chinel, 3 Décembre 2018.

  1. chinel

    chinel XLDnaute Occasionnel

    Inscrit depuis le :
    3 Juin 2007
    Messages :
    354
    "J'aime" reçus :
    0
    Utilise:
    Excel 2007 (PC)
    Bonjour tout le monde ! petit question avec la fonction "si"
    j'ai une colonne et je doit mettre dedans des horaires.
    exemple:
    si le mardi 1 janvier 2019 je mets 14h00-22h00 (en 2019 la première semaine de janvier compte que 4 jours)
    automatiquement la semaine d'après se note en 06h00-14h00
    et la semaine encore d'après se note en 22h00-06h00
    ainsi de suite jusqu'au 31 décembre sachant qu'il n'y a que 3 pauses et 5 jours de travail (du lundi au vendredi inclus)


    Merci
     
  2. Chargement...

    Discussions similaires - condition Forum Date
    Toutes versions FOR AVEC 2 CONDITIONS Forum Excel il y a 52 minutes
    XL 2013 Appliquer une macro sous condition Forum Excel Hier à 19:28
    Toutes versions VBA - formatage conditionnel sur date Forum Excel Hier à 07:35
    mise en forme conditionnelle en fonction de la couleur d'une autre cellule Forum Excel Lundi à 14:55
    Mise en forme conditionnelle ou VBA selon valeur Forum Excel Vendredi à 16:41

  3. Modeste geedee

    Modeste geedee XLDnaute Barbatruc

    Inscrit depuis le :
    8 Mars 2012
    Messages :
    6475
    "J'aime" reçus :
    791
    Sexe :
    Masculin
    Utilise:
    Excel 2007 (PC)
    pour résumer :
    j'ai pas de scie :confused:
    j'ai beaucoup de colonnes...:rolleyes:
    3 horaires sont possibles par roulement

    travailler avec la Fonction N°_SEMAINE et la fonction MOD
    =CHOISIR(1+MOD(N°_semaine(ladate) ; 3 ) ;{"14h-22h";"6h-14h";"22h-06h"})
     
  4. job75

    job75 XLDnaute Barbatruc

    Inscrit depuis le :
    15 Mai 2008
    Messages :
    25805
    "J'aime" reçus :
    2196
    Sexe :
    Masculin
    Habite à:
    Paris
    Utilise:
    Excel 2013 (PC)
    Bonjour chinel, Modeste geedee, le forum,

    Pas compris les "3 pauses" mais avec les dates de l'année en colonne A mettre en B1 :
    Code (Text):
    =SI(JOURSEM(A1;2)>5;"";CHOISIR(1+MOD(NO.SEMAINE(A1)-1;3);"14h00-22h00";"06h00-14h00";"22h00-06h00"))
    A+
     
  5. chinel

    chinel XLDnaute Occasionnel

    Inscrit depuis le :
    3 Juin 2007
    Messages :
    354
    "J'aime" reçus :
    0
    Utilise:
    Excel 2007 (PC)
    voici un exemple
     

    Pièces jointes:

  6. job75

    job75 XLDnaute Barbatruc

    Inscrit depuis le :
    15 Mai 2008
    Messages :
    25805
    "J'aime" reçus :
    2196
    Sexe :
    Masculin
    Habite à:
    Paris
    Utilise:
    Excel 2013 (PC)

    Pièces jointes:

  7. Modeste geedee

    Modeste geedee XLDnaute Barbatruc

    Inscrit depuis le :
    8 Mars 2012
    Messages :
    6475
    "J'aime" reçus :
    791
    Sexe :
    Masculin
    Utilise:
    Excel 2007 (PC)
    upload_2018-12-3_13-35-22.png upload_2018-12-3_13-36-34.png
    :cool: petite modification pour s'affranchir de la fonction NO_semaine qui donne souvent 2 n° de semaines différents pour la semaine à cheval sur le changement d'année
    =SI(JOURSEM(A1;2)>5;"";CHOISIR(1+MOD(ENT(A1-2)/7;3);"06h00-14h00";"22h00-06h00";"14h00-22h00"))
    upload_2018-12-3_13-38-52.png
     
  8. job75

    job75 XLDnaute Barbatruc

    Inscrit depuis le :
    15 Mai 2008
    Messages :
    25805
    "J'aime" reçus :
    2196
    Sexe :
    Masculin
    Habite à:
    Paris
    Utilise:
    Excel 2013 (PC)
    chinel a parlé des dates du 1er janvier au 31 décembre, dans ce cas la fonction NO.SEMAINE va bien.
     
  9. Modeste geedee

    Modeste geedee XLDnaute Barbatruc

    Inscrit depuis le :
    8 Mars 2012
    Messages :
    6475
    "J'aime" reçus :
    791
    Sexe :
    Masculin
    Utilise:
    Excel 2007 (PC)
    :p rendez-vous donc en fin d'année 2019 pour élaboration du planning 2020...
    ;):cool:
     
  10. job75

    job75 XLDnaute Barbatruc

    Inscrit depuis le :
    15 Mai 2008
    Messages :
    25805
    "J'aime" reçus :
    2196
    Sexe :
    Masculin
    Habite à:
    Paris
    Utilise:
    Excel 2013 (PC)
    Re,
    Oui mais si l'on veut un planning sur plusieurs années entrer en B1:B21 les horaires du 1er janvier 2019 au 21 janvier2019 (3 semaines complètes).

    Puis entrer en B22 cette formule à tirer vers le bas =""&B1

    Fichier (2).

    A+
     

    Pièces jointes:

  11. chinel

    chinel XLDnaute Occasionnel

    Inscrit depuis le :
    3 Juin 2007
    Messages :
    354
    "J'aime" reçus :
    0
    Utilise:
    Excel 2007 (PC)
    Merci beaucoup ! j'admire votre savoir faire et votre rapidité pour vos réponses ! Bonne soirée
     

Partager cette page