condition si cellule contient une date

phil69

XLDnaute Occasionnel
bonjour le forum

qu'elle formule pour prndre en compte si une cellule contient une date ou pas

expl: si a1 05/05/06 alors b5 =" "

si a1 1258634 ou autre =" text"

merci atoutes et tous

phil69
 
Dernière édition:

Catrice

XLDnaute Barbatruc
Re : condition si cellule contient une date

Bonjour,

Ci-joint un exemple avec la fonction CELLULE.
On teste le format appliqué à la cellule.
 

Pièces jointes

  • Classeur1.xls
    13.5 KB · Affichages: 3 555
  • Classeur1.xls
    13.5 KB · Affichages: 3 103
  • Classeur1.xls
    13.5 KB · Affichages: 2 815

Staple1600

XLDnaute Barbatruc
Re : condition si cellule contient une date

Bonsoir


Une autre facon (en créant une fonction personnalisée)

Function ESTDATE(R As Range) As Boolean
Application.Volatile
If IsDate(R) Then ESTDATE = True
End Function

et ensuite

en B5
=SI(ESTDATE(A1)=VRAI;"";"texte")
 

Menira

XLDnaute Nouveau
Re : condition si cellule contient une date

Bonjour,

J'ai la même question que Phil, mais ne suis pas assez douée en Excel pour comprendre vos explications. Pouvez-vous m'aider?

Je cherche à mettre en A6 que si les colonnes N ou O ou P ou Q ou R contiennent une date alors vrai, alors faux

Merci d'avance pour votre aide
 

Menira

XLDnaute Nouveau
Re : condition si cellule contient une date

Apparemment même pour formuler la question je ne suis pas douée ;-)

Ce que je voudrais en fait est que

Dans ma colonne A ligne 1, apparaisse soit "Attention" soit "" (rien).

La mention "attention" devrait apparaître à partir du moment où l'une de ces cellules N1,O1, P1, Q1, R1 est rempli par une date. Je voudrais pouvoir reproduire cette formule sur chacune des lignes de mon tableau ( Pour que A2 prenne la mention "attention" si au moins l'une des cellules ( N2, O2 , P2 , Q2 ou R2) contiennent une date et la mention "" si aucune de ces colonnes ne contient une date sur ma ligne.

J'espère que ma question est un peu plus claire ^^

Si vous avez la réponse pouvez-vous me détailler la façon de procéder que je puisse reproduire cela moi même?


Merci beaucoup,
 

excfl

XLDnaute Barbatruc
Re : condition si cellule contient une date

Bonsoir le forum,

A2
Code:
=SI(SI(GAUCHE(CELLULE("format";N2);1)="D";1;0)+SI(GAUCHE(CELLULE("format";O2);1)="D";1;0)+SI(GAUCHE(CELLULE("format";P2);1)="D";1;0)+SI(GAUCHE(CELLULE("format";Q2);1)="D";1;0)+SI(GAUCHE(CELLULE("format";R2);1)="D";1;0)>0;"Attention";"")
A tirer vers le bas.
 

Menira

XLDnaute Nouveau
Re : condition si cellule contient une date

Merci c'est super !

Afin de ne pas polluer le forum avec mes questions incessantes et donc lasser ses membres...Pourriez-vous me conseiller un ouvrage qui traite d'Excel avec des mots très simples (je ne suis pas très douée) mais qui aille à contrario assez loin dans ses explications car professionnellement j'aurais besoin de dépasser les manipulations basiques?

En vous remerciant ;-)
 

excfl

XLDnaute Barbatruc
Re : condition si cellule contient une date

Je n'ai pas d'ouvrage qui traite d'excel à conseiller.

Le web et ce forum sont riches en archives.

Les contributeurs répondent à pratiquement toutes les demandes, des plus simples aux plus complexes, sans jamais se lasser.
 

Discussions similaires

Réponses
11
Affichages
386
Haut Bas