XL 2010 Compter une fois un élément avec une date donnée

nba31

XLDnaute Nouveau
Bonjour,

J'ai un fichier qui traite de réclamations clients sur des engins en leur possession.
Chaque engin a un numéro de série.

Mon objectif est de compter pour chaque mois le nombre de réclamations ainsi que le nombre d'engins impactés. Par exemple:
Avril: 51 réclamations pour 10 engins
Mars: 46 réclamations pour 7 engins

Mes premiers résultats ne sont pas terribles sous TCD car Excel me compte tous les engins. Je voudrais compter les occurences pour un mois donnée.
C'est à dire par exemple pour Mars combien de fois la machine FRS003 a généré des réclamations clients.
J'espère avoir été assez clair.
Vous trouverez en PJ un fichier XLS ;-)
Et merci pour votre aide.
Harry
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonjour nba31, bienvenue sur XLD, salut Roblochon,

Formule matricielle en I2, à valider par Ctrl+Maj+Entrée et tirer vers le bas :
Code:
=SIERREUR(INDEX(T;PETITE.VALEUR(SI(NON(NB.SI(I$1:I1;INDEX(T;;7)));LIGNE(T)-1);1);7);"")
Formule en J2, à tirer vers la droite et le bas :
Code:
=SIERREUR(EXP(LN(SOMMEPROD((INDEX(T;;7)=$I2)*(ANNEE(INDEX(T;;1))=ANNEE(J$1))*(MOIS(INDEX(T;;1))=MOIS(J$1)))));"")
A+
 

Fichiers joints

nba31

XLDnaute Nouveau
Bonjour nba31, bienvenue sur XLD, salut Roblochon,

Formule matricielle en I2, à valider par Ctrl+Maj+Entrée et tirer vers le bas :
Code:
=SIERREUR(INDEX(T;PETITE.VALEUR(SI(NON(NB.SI(I$1:I1;INDEX(T;;7)));LIGNE(T)-1);1);7);"")
Formule en J2, à tirer vers la droite et le bas :
Code:
=SIERREUR(EXP(LN(SOMMEPROD((INDEX(T;;7)=$I2)*(ANNEE(INDEX(T;;1))=ANNEE(J$1))*(MOIS(INDEX(T;;1))=MOIS(J$1)))));"")
A+

Rebonjour JOB75,

Dans ta formule ((INDEX(T;;7)=$I2), comment fais-tu pour définir la valeur T et que pour la formule aille la chercher dans la cellule qui en parle. Je n'arrive pas à trouver car je suis en train d'intégrer cette formule dans un fichier plus gros.
Merci
NBA31
 

mat5100

XLDnaute Nouveau
Bonjour,
Je pense que cela peut très bien marcher pour le TCD.
Tu peux refaire une colonne mois à gauche puis ensuite faire un TCD qui:
- filtre sur le mois
- met les serial numbers en ligne (count of serial number)
- compte les serial numbers en Values

je l'ai fait et cela marchait très bien, j'espère que c'est ce que tu voulais
 

Discussions similaires


Haut Bas