XL 2016 Compter un nombre entre deux dates suivant une condition

Guillaume T

XLDnaute Nouveau
Bonjour,

Dans le cadre de mon alternance j'ai besoin de mettre en place un tableau de suivi automatique du nombre de situations dangereuses, presque accident et incidents premiers secours relevés par mois (Image 3- tableau 1). Pour cela j'ai créé une colonne avec les dates (ici mois de février image 4 - tableau 2) ainsi qu'une liste déroulante associée (image 2 - tableau 2) où je vais choisir le type de situation. A l'heure actuelle je rentre manuellement dans chaque case le nombre de situations relevées dans le mois et j'aimerai bien l'automatiser avec une formule que je n'arriver pas à trouver. J'ai seulement réussi à créer une formule qui va me compter le nombre de situations (toutes confondues) relevées dans le mois sans la seconde condition qui est de savoir s'il s'agit d'un incident, presque accident ou situation dangereuse. =NB.SI(F4:F52,">=2/4/2020")-NB.SI(F4:F52,">-2/24/2020"). Si quelqu’un peut m'aider à automatiser ce tableau qui me faciliterai beaucoup la vie.

Cordialement,
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonjour Guillaume T, bienvenue sur XLD,

Ce problème devrait se régler avec la fonction SOMMEPROD.

Il faudrait joindre le fichier Excel pour voir les plages concernées.

A+
 

job75

XLDnaute Barbatruc
Le fichier en retour avec cette formule en Feuil2!B4 :
Code:
=SOMMEPROD((ANNEE(Feuil1!$F$2:$F$9)=ANNEE($A4))*(MOIS(Feuil1!$F$2:$F$9)=MOIS($A4))*(Feuil1!$G$2:$G$9=B$1))
à tirer à droite et vers le bas.

Attention à l'orthographe en C1 et D1 !!!

-
 

Fichiers joints

Guillaume T

XLDnaute Nouveau
Re,

Je te remercie vraiment pour ton aide, sans toi je n'aurai pas trouvé. Désolé pour les fautes d’orthographes j'ai écris dans la précipitation.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas