Compter nombre, sans doublons, avec conditions

jackyste88

XLDnaute Nouveau
Bonjour,

J'aimerais compter le nombre de "arrêts chez le client" que mon véhicule a fait sur une période donnée.

J'ai une base de donnée, où il y a le numéro de commande, la date et le numéro du client. Quand sur une même journée le client a 2 commandes, mon véhicule de livraison ne fait qu'un arrêt.

C'est pourquoi j'ai une formule qui compte le nombre d'arrêts, en enlevant les doublons, mais je veux que le jour suivant, il ne considère pas comme un doublon, mais comme un arrêt effectué (cf. document ci-joint).

Est-ce que quelqu'un peut m'aider svp ?

Merci d'avance et cordiales salutations,

Jacques
 

Fichiers joints

mapomme

XLDnaute Barbatruc
Supporter XLD
Bonsoir @jackyste88,

Avec une formule matricielle en G6:
VB:
=SOMME((B2:B33>=G3)*(B2:B33<=H3)*(EQUIV(B2:B33&C2:C33;B2:B33&C2:C33;0)=LIGNE(B2:B33)-1))
Ou avec une formule analogue mais avec validation ordinaire en G7:
VB:
=SOMMEPROD((B2:B33>=G3)*(B2:B33<=H3)*(EQUIV(B2:B33&C2:C33;B2:B33&C2:C33;0)=LIGNE(B2:B33)-1))
 

Fichiers joints

Dernière édition:

jackyste88

XLDnaute Nouveau
Bonjour,

Merci à JHA et à mapomme pour vos réponses ! J'ai opté pour les solutions sans rajout de colonne, plus particulièrement pour la formule analogue.

C'est top ! Merci de votre aide !

Cordialement,

Jacques
 

Discussions similaires


Haut Bas