Résolu Compter les cellules en rouge dans une colonne

jonathanV21

XLDnaute Nouveau
Bonjour a tous,

j'ai une colonne avec des valeurs en rouge et en noir, celle qui sont en rouge sont comprises entre 0 et 5 par exemple,

Dans une cellule je voudrais afficher le nombre de cellules en rouge sur le nombre de cellules ou il y a quelque chose ( noir et rouge) de la colonne.

Par exemple : il y a 6 cellules écrites en rouge sur 10 cellules ou il y a quelque chose écrit.

Je voudrais le résultat : 6/10.

Merci de votre aide !
 

James007

XLDnaute Barbatruc
Bonjour,

Au lieu de vouloir compter les cellules en rouge ... il est plus simple d'utiliser les règles qui colorent tes cellules ...

Encore beaucoup plus simple ... joindre un fichier test pour avoir une solution totalement sur-mesure ...;)
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Essayer cette formule matricielle en rapport avec la MFC.
VB:
=NB(SI(($B$1:$B$9>=$E$2)*($B$1:$B$9<=$E$3)-($B$1:$B$9<>"");$B$1:$B$9))&"/"&NBVAL($A$1:$A$9)-NB.SI($B$1:$B$9;"="&"")
JHA
 

Fichiers joints

jonathanV21

XLDnaute Nouveau
Bonjour à tous,

Essayer cette formule matricielle en rapport avec la MFC.
VB:
=NB(SI(($B$1:$B$9>=$E$2)*($B$1:$B$9<=$E$3)-($B$1:$B$9<>"");$B$1:$B$9))&"/"&NBVAL($A$1:$A$9)-NB.SI($B$1:$B$9;"="&"")
JHA
Compliqué mais ça peut bien servir plus tard ^^ merci
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour à tous,
Johnathan, encore mieux pour éviter d'avoir une chaine de caractères :
=NB.SI.ENS(A1:A10;">=0";A1:A10;"<3")/NB.SI(A1:A9;"<10e9") avec format cellules Fraction. Ca donne 3/7.
 

job75

XLDnaute Barbatruc
Bonjour jonathanV21, James007, excfl, sylvanu, JHA,

Avec cette macro on compte les couleurs appliquées aussi bien par MFC que manuellement :
VB:
Sub Go()
Dim c As Range, n&, p&
For Each c In [B1:B9] 'à adapter
    If c <> "" Then
        n = n + 1 '1er comptage
        If c.DisplayFormat.Font.ColorIndex = 3 Then p = p + 1 '2ème comptage si rouge
    End If
Next
'---restitution---
With [C10] 'à adapter
    .NumberFormat = "@" 'format Texte
    .Value = p & " / " & n
End With
End Sub
A+
 

Fichiers joints

jonathanV21

XLDnaute Nouveau
Bonjour jonathanV21, James007, excfl, sylvanu, JHA,

Avec cette macro on compte les couleurs appliquées aussi bien par MFC que manuellement :
VB:
Sub Go()
Dim c As Range, n&, p&
For Each c In [B1:B9] 'à adapter
    If c <> "" Then
        n = n + 1 '1er comptage
        If c.DisplayFormat.Font.ColorIndex = 3 Then p = p + 1 '2ème comptage si rouge
    End If
Next
'---restitution---
With [C10] 'à adapter
    .NumberFormat = "@" 'format Texte
    .Value = p & " / " & n
End With
End Sub
A+
la macro fonctionne mais quand j'adapte a d'autre valeurs ca bloque au niveau de "If c <> "" Then"
ça me met incompatibilité de type.
 

jonathanV21

XLDnaute Nouveau
Bonjour à tous,
Johnathan, encore mieux pour éviter d'avoir une chaine de caractères :
=NB.SI.ENS(A1:A10;">=0";A1:A10;"<3")/NB.SI(A1:A9;"<10e9") avec format cellules Fraction. Ca donne 3/7.
j'ai essayer avec ta formule ça fonctionne mais quand je vais chercher la cellule ou il y écrit 0 et 3, ça ne fonctionne plus
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas