Compter le nombre de résultats dans des cellules contenant toutes des formules

chajmi

XLDnaute Occasionnel
Bonjour
Les cellules A1:A10 contiennent des formules.
Je veux additionner en A11 le nombre de cellules contenant un résultat (quel qu'il soit)
Je ne peux pas utiliser la formule NON.VIDE car dans tous les cas les cellules contiennent la formules et sont considérées comme non vides.

Merci à qui pourra m'aider
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Un peu à l'aveugle,
Code:
=SOMME(SI(ESTNUM(A1:A10);A1:A10))
Valider en matriciel Ctrl+Maj+Entree

JHA
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Si c'est le nombre de valeur:
Code:
=NB(SI(ESTNUM(A1:A10);A1:A10))
Toujours en matriciel

JHA
 

M12

XLDnaute Impliqué
Bonjour à tous

Code:
=SOMMEPROD((A1:A10<>"")*1)
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Suivant la version excel tu peux essayer aussi:
Code:
=AGREGAT(2;6;A1:A10)
pour le nombre
Code:
=AGREGAT(9;6;A1:A10)
pour la somme
validation ordinaire

JHA
 

Guy_M

XLDnaute Occasionnel
Bonjour,

Malheureusement, AGREGAT ne fonctionne pas si on utilise une formule SI.ERREUR(;"")

Si quelqu'un a une formule directe je suis preneur, actuellement j'utilise
Code:
=NBVAL(A1:A10)-NB.SI(A1:A10;"")
A bientôt
Guy
 

Guy_M

XLDnaute Occasionnel
J'ai fini par retrouver la solution, je l'oublie à chaque fois
Code:
=NB.SI(A1:A10;"><")
En espérant que cela sera utile.
 

Discussions similaires


Haut Bas