XL 2016 Compter le nombre de personnes uniques selon des critères

w6irdo

XLDnaute Nouveau
Hello tout le monde,

J'espère que vous passez un bon dimanche :)
Je sais que mon sujet n'est pas nouveau, mais j'ai beau parcourir les forums, je n'y ai trouvé aucune réponse qui fonctionne pour moi :/

Je cherche à calculer le nombre de participants (colonne A) qui ont terminé (colonne D : "Terminé") une formation (colonne C : "FORMATION").
Mon tableau se présente donc de la manière suivante (en simplifié) :
NB : je vous le mets aussi en PJ

ABCD
1ParticipantsFormationCatégorieStatut
2ArthurExcelFORMATIONTerminé
3ArthurPowerpointFORMATIONTerminé
4ArthurAnglaisFORMATIONÀ organiser
5BertrandNégociationFORMATIONTerminé
6BertrandNégociateur du RAIDCONFÉRENCETerminé
7CorinneUXFORMATIONÀ organiser
8EloïseAdobeFORMATIONÀ organiser
9EloïseTendances PAOCONFÉRENCEÀ organiser
10EloïsePrise de parole en publicFORMATIONTerminé

Dans cet exemple, je devrais trouver comme réponse 3 :
- Arthur pour Excel et Powerpoint
- Bertrand pour Négociation
- Eloïse pour Prise de parole en public

J'ai vraiment besoin que le calcul se fasse automatiquement via une formule ou une macro car le fichier va être visible par des personnes qui ne maîtrisent pas powerpoint et doivent avoir un résultat actualité dès qu'ils ouvrent le fichier (donc pas de TCD ou de filtres).

Ce que j'ai déjà testé, sans succès :
{=SOMMEPROD((A2:A10<>"")*(C2:C10="FORMATION")*(D2:D10="Terminé"))} > Ca me donne 4 parce que ça compte 2 fois "Arthur"

{=SOMMEPROD(SI((A2:A10<>"")*(C2:C10="FORMATION")*(D2:D10="Terminé");1/NB.SI(A2:A10;A2:A10)))} > ça me donne 1,5 je ne sais pas à quoi ça correspond.

Un très grand merci d'avance pour votre aide!
Anaïs
 

Fichiers joints

chris

XLDnaute Barbatruc
Bonjour à tous
Coucou Staple : ouf j'ai cru avoir loupé une journée !

@w6irdo puisque tu as 2016, j'ai utilisé 2 solutions au choix
PowerPivot et un TCD avec distinct count...
PowerQuery où on recupère la valeur dans un tableau donc la ligne d'en-tête n'est pas affichée.

Sans doute faisable par une formule matricielle compliquée... attendre les formulistes...

 

Fichiers joints

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour w6irdo, Staple1600 :),

un essai en fichier joint

Cordialement

EDIT : Bonjour chris :) et bises
 

Fichiers joints

w6irdo

XLDnaute Nouveau
Bonjour à tous
Coucou Staple : ouf j'ai cru avoir loupé une journée !

@w6irdo puisque tu as 2016, j'ai utilisé 2 solutions au choix
PowerPivot et un TCD avec distinct count...
PowerQuery où on recupère la valeur dans un tableau donc la ligne d'en-tête n'est pas affichée.

Sans doute faisable par une formule matricielle compliquée... attendre les formulistes...
Hello Chris,

Merci beaucoup de ta réponse :)
Je ne connais pas du tout PowerQuery et PowerPivot, je vais creuser !
Merci pour l'instant, ça va me faire découvrir de nouvelles fonctionnalités :D
 

w6irdo

XLDnaute Nouveau
Bonjour le Forum,
Bonjour w6irdo, Staple1600 :),

un essai en fichier joint

Cordialement

EDIT : Bonjour chris :) et bises
Hello Jocelyn,

Merci aussi de ta réponse :)
Pour bien comprendre, la liste de prénoms qui apparaît colonne J, tu l'as saisie manuellement ?
 

BOISGONTIER

XLDnaute Barbatruc
Bonjour,


par formule
=NB(1/FREQUENCE(SI((crit1="terminé")*(crit2="formation");EQUIV(particip;particip;0));LIGNE(INDIRECT("1:"&LIGNES(particip)))))
Valider avec maj+ctrl+entrée

S'il y a des lignes vides

=NB(1/FREQUENCE(SI((crit1="terminé")*(crit2="formation")*(particip<>"");EQUIV(particip;particip;0));LIGNE(INDIRECT("1:"&LIGNES(particip)))))

Boisgontier
 

Fichiers joints

Dernière édition:

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas