XL 2016 Compter le nombre de cellules non vides par rapport a une date

Don pépé

XLDnaute Occasionnel
Bonjour,
J'ai une petit tableau pour des factures avec:
-Nom du client (Colonne A)
-Numéro de client (Colonne B)
-Numéro de facture (Colonne C)
-Montant de facture (Colonne D)
-Date de facture - sous la forme(01/01/2018) (Colonne E)
Je voudrais savoir comment je peux compter le nombre de clients par rapport à l'année en cour.
J'arrive à compter le montant des factures sur l'année en cour avec :
Code:
=SOMMEPROD((ANNEE(E2:E100)=ANNEE(AUJOURDHUI()))*(D2:D100))
j'ai donc essayer de faire la même chose avec NBVAL:
Code:
=SOMMEPROD((ANNEE(E2:E100)=ANNEE(AUJOURDHUI()))*(NBVAL(A2:A100)))
Mais sa m'affiche un nombrequi na rien avoir.
si quelqu'un a une solution je suis preneur, merci a vous ;)
 

Jacky67

XLDnaute Accro
Bonjour à tous
Essaye ceci
Code:
=SOMMEPROD((ANNEE(E2:E100)=ANNEE(AUJOURDHUI()))*1)
 

Amilo

XLDnaute Accro
Bonjour le forum,
merci a vous
petite question @Jacky67 a quoi correspond le (1) apres * ??
Cette partie de la formule (ANNEE(E2:E100)=ANNEE(AUJOURDHUI())) renvoie VRAI si la condition est remplie sinon FAUX,
On multiplie tous les résultats VRAI ou FAUX par *1 pour obtenir 1 ou 0
Ensuite la fonction sommeprod() fait la somme des 1 et 0 pour obtenir un nombre
On peut également écrire également avec -- au lieu de *1
Code:
=SOMMEPROD(--(ANNEE(E2:E100)=ANNEE(AUJOURDHUI())))
Concernant ce que vous souhaitez, nous ne savons pas si le nombre de clients doit être avec ou sans doublon ?

Bonne journée
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas