XL 2019 compter heures de nuit

lolo42

XLDnaute Occasionnel
Bonsoir,

comment compter les heures en colonne C en conservant le format cellules colonne D10 à E14.
J'y arrive uniquement en changeant le format cellule D31 E31 ainsi que la formule C31 !! mais ce n'est pas ce que je souhaite.
Je voudrais garder le format "Nombre" pour les heures début et fin de poste.

merci de votre aide encore.
 

Fichiers joints

lolo42

XLDnaute Occasionnel
Bonsoir lolo42.

Essayez en C4 :
=SI(E4="";"";MOD((E4/24)-(D4/24);1)*24)
Je sais pas comment vous faite pour trouver toujours la bonne formule!
Votre correspond parfaitement a mes attentes, alors que je cherche depuis hier et rien trouvé de concluant jusqu'ici!
Vos êtes vraiment des pro en la matière!
Merci encore beaucoup pour votre aide à vous et à tous.
Cordialement
 

Victor21

XLDnaute Barbatruc
Supporter XLD
Re,

Explication : 1 c'est équivalent à 1:00 * 24 (puisqu'il y a 24 h dans une journée (comptée pour 1 par Excel)
On commence donc par diviser les décimaux représentant des heures par 24 pour obtenir des heures, et à la fin, on re-multiplie par 24 pour retomber sur des décimaux.
 

Discussions similaires


Haut Bas