XL 2016 Compter différents items

pompaero

XLDnaute Occasionnel
Bonjour le forum,

Je cherche à compter différents items, j'ai trouvé avec sommeprod l'addition d'un seul item.
En F4, par exemple, il faudrait que soit inscrit 2 car il y a un G8 et un G10.

Est-ce que ma formule a une base correct ? certe à améliorer j'imagine.

pompaero
 

Fichiers joints

Efgé

XLDnaute Barbatruc
Bonjour
Ta formule est bonne. Il n'y a qu'un seul G8 avec en $B$13:$B$17 "SP"
Cordialement

Au temps pour moi, je pense que JHA, que je salut, à mieux compris la demande que moi....
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Pas sur de tout saisir, à essayer en "D3"
VB:
=NB.SI.ENS($B$13:$B$17;$B3;D$13:D$17;"G*")
Copier vers la droite et le bas

JHA
 

Fichiers joints

pompaero

XLDnaute Occasionnel
Bonjour efgé, JHA

efgé, effectivement JHA à mieux compris la demande "Lol" mais merci tout de même d'avoir répondu.
JHA, du coup ta proposition correspond bien à mon attente. Je vais tenter.
Merci

pompaero
 

Discussions similaires


Haut Bas