Compter des valeurs identiques

Lamoriciere

XLDnaute Nouveau
Bonjour,
Je travaille sous XP avec Excel 2002.
Je recherche le moyen de compter le nombre de valeurs identiques dans une colonne contenant des n° d'ordre tels que 3z 158, 3z 360 etc. Pour l'instant je piétine, je recherche donc votre aide pour trouver un code VBA adéquat.
Grand merci
 

sylv900

XLDnaute Occasionnel
salut
j'ai déjà utiliser une métode qui consiste à
_ranger la colonne par ordre croissant
_affecter à une variable la première case de la colonne
_dans une boucle 'tant que la valeur de la valeur de la case =variable' , on incrémente un entier qui sera affecter à une variable à la fin de la boucle
_affecter à la variable la nouvelle valeur
_ et ainsi de suite grace à une boucle 'for i= 1 to nombre de ligne'

désolé de ne pas te fournir le code mais je n'ai pas remis la main dessus

bon courage
 

JeanMarie

XLDnaute Barbatruc
Bonjour

En formule dans une feuille de calcul
=SOMMEPROD((1/NB.SI(A1:A100;A1:A100))*1)
la plage de cellules est A1:A100, elle ne doit contenir de cellules vides

Formule acceptant les cellules vides, formule à valider par Ctrl+Shift+Entrer.
=SOMMEPROD((SI(ESTVIDE(A1:A100);0;1/NB.SI(A1:A100;A1:A100))*1))

SOMMEPROD comme les formules matricielles n'aiment pas les références de colonnes ou de lignes entières.

@+Jean-Marie
 

Lamoriciere

XLDnaute Nouveau
Bonjour,
Excusez-moi pour ce retard mais, je me suis seulement remis à mon problème maintenant. Votre réponse a tout débloquer. Encore merci.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas