Résolu COMPTER cellule non vide sans formule

chaelie2015

XLDnaute Accro
Bonsoir
Je souhaite compter le Nombre de cellules de A5 : A10 non vide sans compter la formule dans la cellule.
A+
 

job75

XLDnaute Barbatruc
Bonsoir chaelie2015,

S'il faut exclure les cellules contenant une formule il faut une macro.

Mais s'il s'agit de compter les cellules non vides contenant autre chose qu'un texte vide "" ou un espace :
Code:
=NB.SI(A5:A10;"><")
A+
 

chaelie2015

XLDnaute Accro
Bonsoir chaelie2015,

S'il faut exclure les cellules contenant une formule il faut une macro.

Mais s'il s'agit de compter les cellules non vides contenant autre chose qu'un texte vide "" ou un espace :
Code:
=NB.SI(A5:A10;"><")
A+
Bonsoir job

moi j'ai utilisé NBVAL(A5:A10) est ca n'a pas fonctionné.
merci pour la réponse
a+
 

jmfmarques

XLDnaute Accro
Bonjour chaelie2015
Je souhaite compter le Nombre de cellules de A5 : A10 non vide sans compter la formule dans la cellule.
est, tel qu'écrit, peu compréhensible.
- une cellule contenant une formule n'est pas une cellule vide. elle n'en est pas non plus une si la formule retourne ""
- que veux-tu donc compter très exactement (en utilisant les bons termes) ?
 

mapomme

XLDnaute Barbatruc
Supporter XLD
Bonsoir à tous,

Une autre formule pour compter les cellules vraiment non vides (je crois)
VB:
=SOMMEPROD(--(ESTLOGIQUE(A5:A12)+ESTTEXTE(A5:A12)+ESTNUM(A5:A12)+ESTERREUR(A5:A12)))
 

Fichiers joints

Dernière édition:

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas