Comptabilisation par date

nelson29

XLDnaute Nouveau
Bonjour,
Je recherche une formule pour compter des formations par date (par année et par mois), et aussi par personne sur une année. J'ai mis un fichier joint, je reste dispo si besoin,
D'avance Merci
Cordialement
 

Fichiers joints

R@chid

XLDnaute Barbatruc
Bonjour,
en H13 :
Code:
=SOMMEPROD((MOIS($B$2:$B$9)=MOIS($G13))*(ANNEE($B$2:$B$9)=$G$10)*($C$2:$C$9=H$12))
en H30 :
Code:
=SOMMEPROD((ANNEE($B$2:$B$9)=$G$28)*($A$2:$A$9=$F30)*($C$2:$C$9=H$29))
les deux formules à tirer vers le bas et vers la droite
@ adapter pour les tableaux de 2016.

un TCD sera plus pratique pour faire ce calcul.


@ + +
 

nelson29

XLDnaute Nouveau
Juste pour information est il possible de faire la même chose avec une date butoir, exemple ne prendre en compte que les dates après juin 2015. j'ai essayé avec la formule, en mettant en S10 la date de référence:
=SOMMEPROD((MOIS($B$2:$B$9)=MOIS($G13))*(ANNEE($B$2:$B$9)>=$S$10)*($C$2:$C$9=T$12))
mais cela ne marche pas !
Merci
 

Fichiers joints

nelson29

XLDnaute Nouveau
Tout à fait, j'ai voulu arrêter le décompte à fin 2015 (31/12/2015) en mettant en T10 la date de fin, mais Bug

=SOMMEPROD(($B$2:$B$9>FIN.MOIS($S$10;$T$10))*($A$2:$A$9=$S13)*($C$2:$C$9=T$12))
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas