XL 2016 Compiler RechercheV et Contient

anthooooony

XLDnaute Occasionnel
Bonjour CherExcelDownloadiens,

Je cherche à savoir s'il existe une compilation entre la recherche V et le contient. Je dois en colonne F récuperer l'information de la cellule N.

Le probleme c'est que j'ai une colonne avec des champs Concatener, raison pour laquelle j'imagine que le contient peutfonctionner mais je n'en suis pas sur.

En colonne A et C j'ai un compte comptable et une catégorie. En L j'ai a nouveau le compte comptable, et en M j'ai la catégorie(mais pas toute seule, avec d'autres catégorie) pour enfin récuperer l'information de la colonne N.

En exemple la cellule A4 a comme compte comptable 60200, en C catégorie 1. en colonne L j'ai 60200 et en M le *1* le résultat attendu est 62695
En exemple 2. La cellule A7 a comme compte comptable 60200, en C catégorie 4. en colonne L j'ai 60200 et en M *4* le résultat attendu est 60000

1567787477280.png


Auriez vous une piste? le 'contient' est il exploitable pour cette situation?

en vous remerciant par avance de votre aide,

Anthooooony
 

Fichiers joints

R@chid

XLDnaute Barbatruc
Bonsoir,
en F2 :
Code:
=SIERREUR(INDEX(N$4:N$23;PETITE.VALEUR(SI((L$4:L$23=A2)*ESTNUM(CHERCHE(C2;M$4:M$23));LIGNE(INDIRECT("1:"&LIGNES(L$4:L$23))));1));"")
@ valider par Ctrl+Shift+Enter
@ tirer vers le bas

Ne pas laisser de cellules vide dans la colonne C, tu peux toutefois mettre un XXXX si ça fait pas partie des catégories


Cordialement
 

anthooooony

XLDnaute Occasionnel
Quel crack! pas de RechercheV, ni de concatener, ni de Contient, ni de VBA o_O ! tout simplement magnifique merci beaucoup Rachid pour cette aide précieuse.
Bonne journée

Anthooooony
 

Discussions similaires


Haut Bas