Comparer les valeurs de deux colonnes avec vlookup

centurion

XLDnaute Junior
Bonjour les amis,

Je voudrais utiliser cette formule (VLOOKUP) pour comparer les valeurs des colonnes A et B.
Si une valeur de la colonne B est aussi présente dans la colonne A :
Affiche cette valeur dans la colonne C, dans la même ligne de la valeur qui lui correspond dans la colonne A
Si aucune valeur ne correspond, la colonne D affiche #N/A (ou reste en blanc)
Je joins le fichier !

Merci beaucoup de votre aide
Cordialement
Centurion
 

Fichiers joints

vgendron

XLDnaute Barbatruc
Re : Comparer les valeurs de deux colonnes avec vlookup

Bonjour

en D2 tu tapes
=EQUIV(B2;$A$2:$A$2305;0)
ca te donne la position de la valeur B2 dans la range (A2:A2305)

dans ton fichier le premier resultat apparait à la ligne 197: la valeur AXXAXXUXXGXX
est en ligne 6 (+1: à cause de la ligne d'entete)
 

vgendron

XLDnaute Barbatruc
Re : Comparer les valeurs de deux colonnes avec vlookup

pour plus de clarté dans la colonne
=SI(ESTNA(EQUIV(B2;$A$2:$A$2305;0));"";EQUIV(B2;$A$2:$A$2305;0))
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas