1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

Comparer deux plages de date

Discussion dans 'Forum Excel' démarrée par OursOuzbek, 4 Décembre 2018.

  1. OursOuzbek

    OursOuzbek XLDnaute Nouveau

    Inscrit depuis le :
    6 Septembre 2018
    Messages :
    5
    "J'aime" reçus :
    0
    Bonjour,

    Je cherche à comparer et compter les valeurs de deux plages de cellules, mais je n'arrive pas à obtenir le résultat souhaité avec la formule nb.si.

    En clair :

    Deux colonnes A et B remplies de dates. La plupart des B sont inférieures aux A, sauf certaines, et c'est ces certaines qu'il me faut. (sachant qu'en taille réelle, ce sont des colonnes à plusieurs milliers de lignes)

    J'aimerais compter le nombre de Celulle de la colonne B qui sont supérieures à leur vis-à-vis de la colonne A.

    Une sorte de nombre si mais avec une partie critère variable : =Nb.SI(B1:B10;">"&A1:A10?)

    Existe-t-il une subtilité dans la formule que je n'ai pas compris, ou faut-il passer par du VBA ?

    Merci d'avance !
     

    Pièces jointes:

  2. Chargement...

    Discussions similaires - Comparer deux plages Forum Date
    XL 2010 Comparer deux plages de cellules et copier sur une troisième Forum Excel 18 Septembre 2016
    Comparer deux plages avec critères d'exclusion et sans doublon Forum Excel 5 Novembre 2012
    Comparer deux plages de données Forum Excel 28 Juillet 2005
    Comparer deux fichiers Forum Excel 2 Août 2018
    Toutes versions code vba pour comparer deux feuilles Forum Excel 21 Juin 2018

  3. vmax01

    vmax01 XLDnaute Occasionnel

    Inscrit depuis le :
    17 Février 2008
    Messages :
    176
    "J'aime" reçus :
    6
    bonjour, a essayer ....

    =SOMMEPROD((A1:A10<B1:B10)*1)

    bonne journée.
     
  4. job75

    job75 XLDnaute Barbatruc

    Inscrit depuis le :
    15 Mai 2008
    Messages :
    25766
    "J'aime" reçus :
    2191
    Sexe :
    Masculin
    Habite à:
    Paris
    Utilise:
    Excel 2013 (PC)
    Bonjour OursOuzbek, vmax01,
    Code (Text):
    =SOMMEPROD(N(A1:A10<B1:B10))
    N() prend 3 octets en mémoire alors que ()*1 en prend 5.

    --() prend aussi 3 octets.

    A+
     
    vmax01 aime votre message.
  5. OursOuzbek

    OursOuzbek XLDnaute Nouveau

    Inscrit depuis le :
    6 Septembre 2018
    Messages :
    5
    "J'aime" reçus :
    0
    Arf, c'était la fameuse SOMMEPROD.

    J'en ai souvent entendu parler, j'ai jamais réellement compris comment elle fonctionnait !

    En tout cas, ça marche impeccable, merci à vous deux !
     

Partager cette page