Comparer deux plages de date

OursOuzbek

XLDnaute Nouveau
Bonjour,

Je cherche à comparer et compter les valeurs de deux plages de cellules, mais je n'arrive pas à obtenir le résultat souhaité avec la formule nb.si.

En clair :

Deux colonnes A et B remplies de dates. La plupart des B sont inférieures aux A, sauf certaines, et c'est ces certaines qu'il me faut. (sachant qu'en taille réelle, ce sont des colonnes à plusieurs milliers de lignes)

J'aimerais compter le nombre de Celulle de la colonne B qui sont supérieures à leur vis-à-vis de la colonne A.

Une sorte de nombre si mais avec une partie critère variable : =Nb.SI(B1:B10;">"&A1:A10?)

Existe-t-il une subtilité dans la formule que je n'ai pas compris, ou faut-il passer par du VBA ?

Merci d'avance !
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonjour OursOuzbek, vmax01,
Code:
=SOMMEPROD(N(A1:A10<B1:B10))
N() prend 3 octets en mémoire alors que ()*1 en prend 5.

--() prend aussi 3 octets.

A+
 

OursOuzbek

XLDnaute Nouveau
Arf, c'était la fameuse SOMMEPROD.

J'en ai souvent entendu parler, j'ai jamais réellement compris comment elle fonctionnait !

En tout cas, ça marche impeccable, merci à vous deux !
 
Haut Bas