Comparer des dates et garder celle la plus proche d'une valeurs

bougy

XLDnaute Nouveau
Bonjour à tous

Je rencontre un problème et je viens demander un peu d'aide!

Voici l'objet de ma demande:

Dans le cadre du suivi de la maintenance d'un équipement, je souhaite connaitre le nombre de jour qui sépare le dernier entretien avant la date de la panne.

J'ai joints un exemple que j'explique brievement:
mes champs visite 1 à 5 sont les dates des derniers entretiens.
Ces dates peuvent être identiques d'un champ à l'autre
Ces dates peuvent être postérieures à la date de la panne.

Ce que je veux:
C'est la valeur de l'écart mini (50 dans l'exemple).
NB le calcul de l'écart mini n'est pas bon dans l'exemple!!!!
Je veux que les dates soient comparées et je souhaite garder la date la plus proche et compte le nombre de jours qui sépare le dernier entretien de la panne

Je n'ai pas trouvé de formules pour faire ça!

NB: je peux changer / ajouter des colonnes dans le fichier!

D'avance merci à tous du coup de pouce
 

Fichiers joints

bougy

XLDnaute Nouveau
Re : Comparer des dates et garder celle la plus proche d'une valeurs

Bonjour JCGL, et merci.
Le problème de la fonction MAX, c'est que j'ai aussi les dates des entretien après la panne, ce qui ne m’intéresse pas
Mais il s'agit d'une piste intéressante: si je fait un =SI une date de visite > date de panne
est-ce une idée réalisable?
 

JCGL

XLDnaute Barbatruc
Re : Comparer des dates et garder celle la plus proche d'une valeurs

Bonjour à tous,

Tu peux faire ce que tu souhaites si cela correspond à ton souhait (en tout cas avec XL...)

=SI(MAX(A2:E2)>G2;"";G2-MAX(A2:E2))
A+ à tous
 

bougy

XLDnaute Nouveau
Re : Comparer des dates et garder celle la plus proche d'une valeurs

JCGL:
le problème: Si j'ai une date d'entretien > date de visite, je ne récupère pas l'écart!
Or, c'est cet écart qui m’intéresse.

Comment ne pas tenir compte des dates postérieurs à la date de la panne?
Comme dit plus haut, je peux ajouter une colonne supplémentaire pour faire un test!

Je vais essayer dès demain dans le courant de la journée!

encore merci
 

JCGL

XLDnaute Barbatruc
Re : Comparer des dates et garder celle la plus proche d'une valeurs

Bonjour à tous,

Inverse ou modifie les opérateurs.

A+ à tous
 

bougy

XLDnaute Nouveau
Re : Comparer des dates et garder celle la plus proche d'une valeurs

Bon: Je pense que l'on peut largement optimiser le calcul mais bon: j'ai trouvé une solution qui fonctionne, et que je joints:

Je teste chaque date avec un =SI(date entretien > date de visite;"";date entretien)
avec le résultat de chque test, je reprends la formule =date de la panne - MAX(plage de test)
Et ça fonctionne!!!

Merci JCGL!
 

Fichiers joints

bougy

XLDnaute Nouveau
Re : Comparer des dates et garder celle la plus proche d'une valeurs

Merci VIctor.

J'essaye ça dès demain!
 

Discussions similaires


Haut Bas