Comparer 2 listes différentes avec mêmes données

Michel_D

XLDnaute Nouveau
Bonjour à tous,

Je n'ai pas vraiment trouvé d'équivalence à mon problème en recherchant dans le forum.
J'aimerais trouver une formule qui me compare un total sur 2 listes se présentant différemment mais qui comporte les mêmes données.:confused:
Dans le fichier exemple joint, je cherche à mettre une formule dans STOCK 2 qui compare le total de l'ID 1 avec le total de l'ID 1 de la feuille STOCK 1 et qui m'indique si il y a une différence. (Dans l'exemple l'ID 1 et 3 sont différents )
Pfffff pas façile d'expliquer mon problème.
J'ai essayé avec SOMMEPROD mais je n'arrive à rien !:(
Quelqu'un peut m'aider ?

Merci

Michel
 

Fichiers joints

CBernardT

XLDnaute Barbatruc
Re : Comparer 2 listes différentes avec mêmes données

Bonsoir à tous,

Dans la cellule C1 mettre la formule :

=SOMMEPROD(('Stock 1'!$A$2:$A$30=$A2)*('Stock 1'!$B$2:$B$30=$B2)*('Stock 1'!$C$2:$C$30=C$1)*('Stock 1'!$D$2:$D$30))

puis incrementer sur le reste du tableau;
 

Michel_D

XLDnaute Nouveau
Re : Comparer 2 listes différentes avec mêmes données

Bonjour Bernard,

Merci pour cette prompte réponse.
Cette formule m'a grandement aidé, mais je n'ai pas besoin de comparer les colonnes c, d et e...je dois juste comparer le total de l'ID 1 du STOCK1 avec le total de l'ID 1 du STOCK2.
Le résultat (voir classeur joint ) me suffit et j'ai fait une mise en forme conditionnelle si résultat différent.
Un tout grand merci.

Michel
 

Fichiers joints

Michel_D

XLDnaute Nouveau
Re : Comparer 2 listes différentes avec mêmes données

Bonjour,

Tout à fait je mélange complètement mes neurones !
Pas d'erreur sur l'ID 1 !
Merci beaucoup !

Michel
 

Imago38

XLDnaute Nouveau
Re : Comparer 2 listes différentes avec mêmes données

Oups....
Michel, je me rend compte que je suis allé un peu vite tout à l'heure et que j'ai oublié de "dolariser" les plages de cellule.
La bonne est celle-ci, également en PJ

SI(SOMME.SI('Stock 1'!$A$2:$A$22;'Stock 2'!A2;'Stock 1'!$D$2:$D$22)=G2;"idem";"différent")

Bonne soirée !
:)
 

Fichiers joints

Discussions similaires


Haut Bas