XL 2019 comparaison entre deux table et incrémentation

ILOVEUBB

XLDnaute Occasionnel
salut les amis

comme je métrise pas le VBA je vient demandé votre aide svp
voila j'ai deux table Excel feuil1 et feuil2 les deux table sont identiques.
la première table contient 03 colonnes MATRICULE - MONTANT - OBS.
la deuxième table contient 02 colonne MATRICULE - MONTANT.
sauf que le MATRICULE de la deuxième table est consolider mais pas dans la première table
le bute c'est de faire une comparaison entre les deux table par MATRICULE et si on trouve que le MONTANT de la deuxième table est diffèrent de 0 alors ont incrément le contenu de la colonne OBS de la première table de +1

merci pour votre aide
 

Pièces jointes

  • comparaison.xlsx
    44.2 KB · Affichages: 14

ILOVEUBB

XLDnaute Occasionnel
C'est que c'est trop vague pour que ça m'inspire.
Il n'est donc pas utile de vérifier si les sommes de montants sont égales ?
Ni de pouvoir ouvrir le classeur contenant la seconde feuille ?
Merci c'est gentille de votre part de s'intéressée a mon projet
voici une copie du fichier original que j'ai récupérer d'un collègue après modification ,
d'un débutant qui maîtrise pas bien le VBA 🙃
 

Pièces jointes

  • OS V1.xlsm
    91.8 KB · Affichages: 6

Dranreb

XLDnaute Barbatruc
La feuille avec les totaux par matricule est constituée à partir de la Feuil1 si je comprends bien, c'est pour ça qu'elle est toujours juste ? Il aurait été très facile de la constituer en explorant une collection issue de ma fonction Gigogne.
 

ILOVEUBB

XLDnaute Occasionnel
La feuille avec les totaux par matricule est constituée à partir de la Feuil1 si je comprends bien, c'est pour ça qu'elle est toujours juste ? Il aurait été très facile de la constituer en explorant une collection issue de ma fonction Gigogne.
oui, c'est bien ça
mais je ne sais pas comment faire ?
svp est ce que vous pouvez me corriger le fichier ! si c'est ne pas trop demander
 

Dranreb

XLDnaute Barbatruc
Si vous essayiez de le faire, vous apprendriez de quoi utiliser ma fonction Gigogne à d'autres fins.
Ça reprendrait en gros la structure de la procédure déjà faite, sauf qu'il n'y aurait pas besoin de concaténer les tableaux des deux sources à l'aide de la Function TableUnique, juste prendre les infos de la 1ère source. Après l'objet SsGr possède quelques méthode dont Somme qui pourrait vous éviter de parcourir Matr.Co
Dites moi ce que vous ne comprenez pas dans le principe, mais après ne revenez que lorsque vous serez vraiment bloqué.
 

ILOVEUBB

XLDnaute Occasionnel
Si vous essayiez de le faire, vous apprendriez de quoi utiliser ma fonction Gigogne à d'autres fins.
Ça reprendrait en gros la structure de la procédure déjà faite, sauf qu'il n'y aurait pas besoin de concaténer les tableaux des deux sources à l'aide de la Function TableUnique, juste prendre les infos de la 1ère source. Après l'objet SsGr possède quelques méthode dont Somme qui pourrait vous éviter de parcourir Matr.Co
Dites moi ce que vous ne comprenez pas dans le principe, mais après ne revenez que lorsque vous serez vraiment bloqué.
salut

voila quand j'essaye e cliqué sur la procédure "FusionIncrémentation" l'erreur suivante apparait
Ashampoo_Snap_2021.09.11_22h26m27s_001_.png
 

job75

XLDnaute Barbatruc
Bonjour ILOVEUBB, Bernard, le forum,

Pas du tout suivi ce fil mais il me semble que le problème posé au post #1 peut se régler par formules.

En C3 =N(SOMMEPROD((A$3:A3=A3)*B$3:B3)<=SOMME.SI(Feuil2!A:A;A3;Feuil2!B:B))

En D3 =REPT("OK";SOMMEPROD((A$3:A3=A3)*B$3:B3)=SOMME.SI(Feuil2!A:A;A3;Feuil2!B:B))

A+
 

Pièces jointes

  • compraison(1).xlsx
    91.6 KB · Affichages: 2

ILOVEUBB

XLDnaute Occasionnel
S'il s'agit de faire la somme des 1 de la colonne OBS introduisez la colonne avec en D3 :
Code:
=SI(A3=A4;"";SOMME.SI(A$3:A3;A3;C$3:C3))
désolé je me suis mal exprimer
voila le fichier original pour que vous comprendrez bien
le problème c'est de réalisé une recap mensuel pour chaque mois contenant le matricule et la mensualité. et ensuite augmenté de +1 chaque mensualité pour chaque article 🤕 dans la feuille 1


merci pour votre aide
 

Pièces jointes

  • OS V1.xlsm
    91.8 KB · Affichages: 1

Discussions similaires

Membres actuellement en ligne

Statistiques des forums

Discussions
290 755
Messages
1 910 209
Membres
176 539
dernier inscrit
altheamain
Haut Bas