comparaison date dans formule excel

S

sev

Guest
Bonjour,

c quoi la syntaxe pour la comparaison de date en formule excel ??????

les formules suivantes ne marchent pas :

=SI(A3<=#1/31/2002#;1;0)
=SI(A3<="31/1/2002";1;0)


Merci !

Séverine
 
M

Monique

Guest
Bonjour,

Ces deux-ci fonctionnent :
=SI(A1<=DATEVAL("2002/1/31");1;0)
=SI(A1<=DATEVAL("31/1/2002");1;0)
Mais tu aurais peut-être intérêt à taper ta date 31/1/2002 dans une cellule
Si tu la mets en D1, ça donne :
=SI(A1<=$D$1;1;0)
 

fred871

XLDnaute Nouveau
Re : comparaison date dans formule excel

Bonjour,

J'aurais voulu savoir comment je peux faire pour comparer 2 dates (2 colonnes differentes) ex A1 et A2 et qu'en A3 j'ai le résultat "oui" ou "non" en la comparant avec la date de A1 + 2an (jour mois année prises en compte)

Merci pour vos réponses
 

Modeste geedee

XLDnaute Barbatruc
Re : comparaison date dans formule excel

Bonsour®
=SI(MOIS.DECALER(A1;24)>=A2;"OUI";"NON")

on ajoute 24 mois à A1 pour tester par rapport à A2
 

fred871

XLDnaute Nouveau
Re : comparaison date dans formule excel

Re-bonjour,

J'aurais voulu savoir si il était possible de rajouter une condition avec une 3eme colonne

A1= date ; B1 = date ; C1 = Oui ou non

en D1= "Envoi facture" si C1 =Oui et B1 > A1+1mois

est-ce possible?

=SI(MOIS.DECALER(A1;2)>=B1;"OUI";"NON") avec la condition de C1= oui =>résultat= "Envoi facture" sinon "non"
 

fred871

XLDnaute Nouveau
Re : comparaison date dans formule excel

j'ai essayé avec ça :


D1=SI(MOIS.DECALER(A1;2)<=B1;"OUI";SI(C1="OUI";"Envoi Facture";"NON"))

Mais je ne sais pas comment il comprend une case vide...

C1 et A1 sont fixe, par contre B1 peut-être vide.

Actuellement je n'ai pas la réponse attendu: je devrais pour la date retrouver un "non" car ça ne dépasse pas 30 j
 

Fichiers joints

fred871

XLDnaute Nouveau
Re : comparaison date dans formule excel

Je découvre un autre probleme :

en fait j'ai deux réponse à avoir : "Envoi facture" ou "non"

Selon si B1 dépasse de deux mois (pas 30j) la date en A1, et B1 peut -être vide c'est à dire que la valeur à prendre serait (aujourd'hui) si vide.
 

Steven18x

XLDnaute Nouveau
Re : comparaison date dans formule excel

Bonjour,

Je suis dans l'urgence si vous pouvez m'aider..

J'ai un tableau client avec leur date d'arrivée. Je voudrai dans une autre feuille du fichier excel creer un tableau en copiant les infos clients avec le nom l'adresse..ect que j'ai dans la tableau de la feuille 1 seulement si le client est arrivée aprés une certaine date. Je sais pas si vous m'avez compris si oui ca serait vraiment tres gentil de me dire si c'est possible et comment.

Cordialement

Steven
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas