XL 2013 Comment faire disparaître #VALEUR! dans zone de texte (Résolu)

papy 73 ans

XLDnaute Occasionnel
Bonsoir Chers amis,
Comment faire disparaître #VALEUR! dans zone de texte
Voici la formule qui écrit dans la zone de texte :
=SI("AA2"="";"";SI(AA2="Sup";"aaaaaaaaaa";"bbbbbbbbbb"))
En vous remerciant
 
Dernière édition:

Santulud

XLDnaute Occasionnel
bonsoir,

cela dépend du contexte, mais si tu veux simplement que l'erreur ne s'affiche pas, modifie ta formule comme suit:

VB:
=sierreur(ta formule;"")
cela affichera une cellule vide si ta formule ne fonctionne pas
 

papy 73 ans

XLDnaute Occasionnel
Zone de texte "vide" si rien en AA2
=sierreur(=SI("AA2"="";"";SI(AA2="Sup";"aaaaaaaaaa";"bbbbbbbbbb")) ;"")=SI("AA2"="";"";SI(AA2="Sup";"aaaaaaaaaa";"bbbbbbbbbb"))
Vous avez trop d'arguments

=si(erreur(=SI("AA2"="";"";SI(AA2="Sup";"aaaaaaaaaa";"bbbbbbbbbb")) ;"")=SI("AA2"="";"";SI(AA2="Sup";"aaaaaaaaaa";"bbbbbbbbbb"))
Donne Fonction non valide

=SI("AA2"="";"";SI(AA2="Sup";"aaaaaaaaaa";"bbbbbbbbbb")) ;"")=SI("AA2"="";"";SI(AA2="Sup";"aaaaaaaaaa";"bbbbbbbbbb"))
Donne #VALEUR! dans la zone de texte

=SI("AA2"="";"");SI(AA2="Sup";"aaaaaaaaaa";"Pour Mise à jour de l'annuaire")
Donne #VALEUR! dans la zone de texte

=SI("AA2"="";"";SI(AA2="Sup";"aaaaaaaaaa";"bbbbbbbbbb")) ;"")
Affiche la valeurs bbbbbbbbbb

En vous remerciant
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas