Comment créer une liste classée par dates [résolu]

LOLO13130

XLDnaute Nouveau
Bonjour à tous, je ne sais pas si le titre est explicite alors je m'explique :
- dans la plage C8 : C30 figurent des numéros
- dans la plage D8 : D30 figurent des dates
- dans la plage F8 : F30 figurent des données ("A" / "ECA" / "NA")

Je souhaite tout d'abord identifier toutes les lignes possédant la donnée "A" dans la plage F8:F30, puis je souhaite reporter dans les colonnes G et H les numéros et dates correspondants, le tout classé par date (la plus ancienne en H8) et en ignorant les lignes vides.

N'étant vraiment pas doué en VBA, est-il possible de réaliser cette tâche grâce à des formules ?
Et s'il-vous-plaît, pouvez-vous m'indiquer quelles formules utiliser ?

Je joins un fichier au cas où mes explications ne suffisent pas...

Merci d'avance pour votre aide si précieuse pour les débutants en Excel...
Laurent
 

Fichiers joints

mapomme

XLDnaute Barbatruc
Supporter XLD
Bonjour à tous,

Un essai par formule. Voir fichier joint. La formule en G8 est une formule matricielle à valider par la combinaison des trois touches Ctrl+Maj+Entrée.

Formule matricielle en G8:
VB:
=SIERREUR(INDEX(C$1:C$30;ARRONDI(1000000*MOD(PETITE.VALEUR(SI($F$8:$F$30="A";$D$8:$D$30+LIGNE($D$8:$D$30)/1000000);LIGNES(F$8:F8));1);0));"")
 

Fichiers joints

Dernière édition:

LOLO13130

XLDnaute Nouveau
Bonjour,

Regarde si ça te conviens, pour le résultat final, tu le trouveras en feuille 2 avec un TCD.

A plus
Bonjour chezswan et merci d'avoir pris le temps de me répondre.

L'idée d'un tableau dynamique est intéressante mais la solution de mapomme à partir d'une formule matricielle convient mieux à mes besoins.

Merci encore et bonne journée.
Laurent
 

LOLO13130

XLDnaute Nouveau
Bonjour à tous,

Un essai par formule. Voir fichier joint. La formule en G8 est une formule matricielle à valider par la combinaison des trois touches Ctrl+Maj+Entrée.

Formule matricielle en G8:
VB:
=SIERREUR(INDEX(C$1:C$30;ARRONDI(1000000*MOD(PETITE.VALEUR(SI($F$8:$F$30="A";$D$8:$D$30+LIGNE($D$8:$D$30)/1000000);LIGNES(F$8:F8));1);0));"")
Bonjour mapomme,

Un énorme MERCIIII !!! Ta solution est parfaite et fonctionne à merveille.
Par contre étant vraiment débutant, je n'ai pas compris dans quel but et quand valider la formule matricielle par la combinaison des 3 touches, puisque quand je modifie les valeurs, tout s'actualise automatiquement, comme par miracle (pour moi ;-) ...

Depuis ta réponse, j'essaie désespérément d'adapter la formule matricielle à mon autre besoin du même genre, mais sans succès et avec quelques cheveux en moins... S'il-te-plaît, peut-tu m'aider ? Je suis certain que c'est dans tes compétences mais je comprendrais que tu n'es pas le temps ou l'envie de t'y pencher (sûrement d'autres débutants comme moi à dépatouiller...).

Je cherche, pour les feuilles "Benjamines" et "Benjamins", à établir une liste répondant à 2 conditions ("E1" à identifier dans la plage D6 : D105 ET "OUI" à identifier dans la plage G6 : G105), classée cette fois par ordre alphabétique. Puis, je cherche à fusionner ces 2 listes dans la feuille "Présences B-J1", avec la liste des benjamines en 1er (honneur aux dames ;-).

Je joins le fichier pour plus de clarté.

Encore un grand merci à toi et au forum en général, qui est toujours aussi efficace !
Bonne journée.
Laurent
 

Fichiers joints

LOLO13130

XLDnaute Nouveau
Rebonjour à tous,

mapomme, je ne sais vraiment pas comment te remercier. Tu as encore tapé dans le mille avec ta macro qui s'exécute à la vitesse grand V !! C'est exactement ce qu'il me fallait : tu as réalisé mon impossible ;-)
Je vais essayer d'adapter ça au reste de mon problème (faire une liste fusionnant 4 listes : minimes filles + minimes garçons + cadettes + cadets selon le même principe)...

Encore merci pour le temps consacré à m'aider et bravo pour ton niveau de compétence ! J'espère pouvoir te renvoyer l'ascenseur un jour, mais sûrement pas sur ce forum ;-)
Bonne continuation et merci le forum.
Laurent
 

Discussions similaires


Haut Bas