comment créer des intervalles à partir d'heures

erigane

XLDnaute Nouveau
bonjour,
je suis toute nouvelle sur le forum, je rame un peu sur excel et cherche beaucoup sur internet, mais je n'ai pas trouvé de solution à mon problème..
en fait, j'ai un fichier avec une colonne nombre, et une colonne heure en format 00:00, et je voudrais pouvoir ramener mes heures par tranche de 10 minutes et compter combien j'ai de nbre dans ces intervalles de 10 minutes.. je ne sais pas si c'est vraiment clair?
j'imagine qu'il y a une formule d'abord pour créer mes intervalles d'heures puis je pourrais compter..
je tourne vraiment en rond.. si vous avez des idées?
MErci..

1029417
 

Victor21

XLDnaute Barbatruc
Supporter XLD
Bonjour, erigane et bienvenue sur XLD.
[...]je tourne vraiment en rond.. si vous avez des idées?
[...]
On ne peut pas faire grand-chose sur une image, mais si vous pouviez joindre un bout de fichier, et nous préciser si vous désirez le nombre de nombres ou le total des nombres par tranche de 10 minutes, nous pourrions vous aider :)
 

erigane

XLDnaute Nouveau
bonjour Victor21,
merci pour ta réponse! en effet c'est peut être plus simple avec un fichier, je le mets en pièce jointe :) .
ce que je cherche à calculer c'est en effet le total de nombres par tranche de 10 minutes; mais je n'arrive déjà pas à calculer les intervalles sur la base des heures en colonne B :cool: .
Merci beaucoup en tout cas de prendre le temps d'y jeter un oeil
 

Fichiers joints

erigane

XLDnaute Nouveau
whouhou, je suis juste bluffée. Milles MERCIS Victor21! c'est exactement ce que je cherchais.
Merci encore
 

erigane

XLDnaute Nouveau
Victor21 puis je abuser... je ne comprends pas pourquoi quand je remets la formule sur mon fichier puisqu'il ne s'agissait que d'un extrait ça ne marche pas cette fois :-(
 

Victor21

XLDnaute Barbatruc
Supporter XLD
Re, erigane.

Victor21 puis je abuser...
J'allais vous en prier :)

je ne comprends pas pourquoi quand je remets la formule sur mon fichier puisqu'il ne s'agissait que d'un extrait ça ne marche pas cette fois :-(
Vérifiez et éventuellement rectifiez les zones prises en compte dans les formules : en cliquant à l'intérieur de la zone de formule, les zones prises en compte par celle-ci sont colorées.
1029437
 

erigane

XLDnaute Nouveau
c'est bien ce que j'ai fait, j'ai l'impression d'avoir repris la même formule.. et pourtant cela ne fonctionne plus.. j'ai vérifié les formats de cellules.. je sèche à nouveau :-(
 

Fichiers joints

Victor21

XLDnaute Barbatruc
Supporter XLD
Re, erigane.
c'est bien ce que j'ai fait[...]
Pas vraiment:
La syntaxe est :
SOMME.SI.ENS(somme_plage, plage_critères1, critères1, plage_critère2, critères2)
(=SOMME.SI.ENS($B$3:$B$99;$A$3:$A$99;">="&F1;$A$3:$A$99;"<"&F2))
Et vous avez fait :
SOMME.SI.ENS(plage_critères1, somme_plage, critères1, plage_critère2, critères2)
(=SOMME.SI.ENS($A$3:$A$99;$B$3:$B$99;">="&F1;$A$3:$A$99;"<"&F2))
 

mdo100

XLDnaute Occasionnel
Bonjour erigane,
Re Victor21, ;)

@erigane, personnellement je préfère la fonction SOMMEPROD ce qui donnerait:
En "F3"
VB:
=SOMMEPROD(($A$3:$A$500>=F1)*($A$3:$A$500<F2)*$B$3:$B$500)
Tirer vers la droite autant que nécessaire.

Cordialement.
 

Discussions similaires


Haut Bas