Comment changer les arguments dans une fonction automatiquement

N

natasia

Guest
Bonjour à tous,

je voulais d'abord remercier déjà tous ceux qui m'ont aidée dans ce forum
comme Coyote, Monique ou Jean-marie


Comme un exemple vaut mieux qu'une longue et douloureuse explication.


Dans feuil1 j'ai 1000lignes saisie et dans mes stats de feuill2 j'ai
des formules comme :

=NBVAL(Feuil1!A2:A1000)
ou
=SOMMEPROD((Feuil1!C2:C1000>=18)*(Feuil1!C2:C1000<30)*(Feuil1!AB2:AB1000=1))

mais lorsque je fais un copier coller d'une autre saisie dans feuil1 qui n'a que 500 lignes ( à la place de 1000) par exemple

il faudrait que les formules de feuil2 se mettent à jour toutes seules
et donc
=NBVAL(Feuil1!A2:A500)
ou
=SOMMEPROD((Feuil1!C2:C500>=18)*(Feuil1!C2:C500<30)*(Feuil2!AB2:AB500=1))

Est-ce cela possible ?
Merci à vous

Cordialement
Natasia
 
C

CBernardT

Guest
Bonsoir Natasia

Si j'ai bien compris, tu veux que tes formules soient à géométrie variable en fonction du nombre de lignes en Feuil1.

A mon humble avis, cela n'est possible que par la modification des éléments des formules.

Pour obtenir ce résultat, le passage par des macros à ajustement automatique semble être plus adapté.

Cordialement

CBernardT
 
N

natasia

Guest
Merci pour votre réponse rapide

donc vous pensez que ce n'est pas possible directement avec des formules excel du genre

ex:
=NBVAL(Feuil1!A2:A'num')

avec num = nombre de ligne


Natasia
 
A

andré

Guest
Salut,

A essayer :

Sélectionner toute la feuille
Menu Edition / Remplacer / Rechercher : 1000 / Remplacer par : 500 / Remplacer tout.

Ândré.
 
A

andré

Guest
Resalut,

Une autre méthode à essayer :

Par le menu Insertion / Nom / Définir / Nommer A1000 : Aµ, C1000 : Cµ, ...
Employer ce nom dans les formules : =NBVAL(Feuil1!A2:Aµ)

Le µ (= micron, sur mon clavier sous le £ à gauche de la touche ENTREE) peut être remplacé par autre chose, par exemple : num, mais µ est plus rapide à encoder.

Lors du changement de feuille, il suffit de modifier la référence du nom et nommer A500 : Aµ

Il y a aussi moyen de nommer 1000 : µ, mais alors il faut modifier les formules comme suit : =NBVAL(Feuil1!A2:INDIRECT("A"&µ))
C'est plus rapide pour la modification, mais plus long pour encoder les formules.

Ândré.
 
A

andré

Guest
Reresalut,

Dernière méthode (enfin je crois !) à essayer :

Tout simplement supprimer les lignes 500 à 999 et les références dans les formules s'adaptent automatiquement.

Ândré.
 
S

STéphane

Guest
bonjour

je cherche toujours comment áccéder en VA aux arguments dúne formule, mais je crois que ce n´est pas possible :-(

Stephane
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas