XL 2010 Comment calculer des nombres qui ne sont pas des nombres

Philippe LAMACHE

XLDnaute Nouveau
Bonjour à tous,

J'ai une formule qui me récupère la fin d'un texte après les ":" (Nbre de lignes traitées : 7 801)

VB:
=SI(A2="";"";DROITE(INDIRECT("'"&A2&"'!A11");NBCAR(INDIRECT("'"&A2&"'!A11"))-TROUVE(":";INDIRECT("'"&A2&"'!A11"))))
J'en ai environ 15 et je souhaiterais les additionner (=SOMME(G2:G20)) mais comme ce ne sont pas des nombres, mon résultat est 0.

Quelqu'un a-t'il une solution ?
Par avance, merci.
 

eriiiic

XLDnaute Barbatruc
Bonjour,

dans tes 2 parties de formule mettre
VB:
--(formule_partie1);--(formule_partie2))
Le 1er moins converti en numérique, le 2nd rétabli le signe.
eric
 
Dernière édition:

CHALET53

XLDnaute Barbatruc
Peut-être :

=SI(A2="";"";DROITE(INDIRECT("'"&A2&"'!A11");NBCAR(INDIRECT("'"&A2&"'!A11"))-TROUVE(":";INDIRECT("'"&A2&"'!A11")))*1)
a+
 

Philippe LAMACHE

XLDnaute Nouveau
Bonjour,

dans tes 2 parties de formule mettre
VB:
--(formule_part1);--(formule_part21)
eric
Bonjour Eric,
VB:
=SI(A2=0;0;DROITE(INDIRECT("'"&A2&"'!A11");NBCAR(INDIRECT("'"&A2&"'!A11"))-TROUVE(":";INDIRECT("'"&A2&"'!A11"))))
Comme ça ? cela ne fonctionne pas.
 

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour Philippe LAMACHE, eriiiic, CHALET53,

Si tu penses que le soucis provient de l'espace il reste à savoir si c'est un espace simple ou insécable donc a tester

avec espace simple

Code:
=SI(A2="";"";substitue(DROITE(INDIRECT("'"&A2&"'!A11");NBCAR(INDIRECT("'"&A2&"'!A11"))-TROUVE(":";INDIRECT("'"&A2&"'!A11")));car(32);"")*1)
avec espace insécable

Code:
=SI(A2="";"";substitue(DROITE(INDIRECT("'"&A2&"'!A11");NBCAR(INDIRECT("'"&A2&"'!A11"))-TROUVE(":";INDIRECT("'"&A2&"'!A11")));car(160);"")*1)
Cordialement
 

Philippe LAMACHE

XLDnaute Nouveau
Bon ...
J'ai trouvé une solution qui fonctionne
VB:
=NBVAL(INDIRECT("'"&A2&"'!B14:B1048576"))
Merci à tous pour votre temps et vos suggestions.
 

Philippe LAMACHE

XLDnaute Nouveau
Bonjour le Forum,
Bonjour Philippe LAMACHE, eriiiic, CHALET53,

Si tu penses que le soucis provient de l'espace il reste à savoir si c'est un espace simple ou insécable donc a tester

avec espace simple

Code:
=SI(A2="";"";substitue(DROITE(INDIRECT("'"&A2&"'!A11");NBCAR(INDIRECT("'"&A2&"'!A11"))-TROUVE(":";INDIRECT("'"&A2&"'!A11")));car(32);"")*1)
avec espace insécable

Code:
=SI(A2="";"";substitue(DROITE(INDIRECT("'"&A2&"'!A11");NBCAR(INDIRECT("'"&A2&"'!A11"))-TROUVE(":";INDIRECT("'"&A2&"'!A11")));car(160);"")*1)
Cordialement
Bonjour Jocelyn,
La première solution me renvoie #VALEUR!
La deuxième me renvoie bien un nombre et ma somme fonctionne à présent.
Merci.
 

Philippe LAMACHE

XLDnaute Nouveau
Bonjour à tous.

Et pourquoi pas, en alternative, un format de nombres personnalisé :
Voir la pièce jointe 1038085
Exemple en pj
Bonjour Patrick,
Merci d'avoir pris le temps pour moi.
Ce que je veux récupérer c'est la valeur (7801 dans mon exemple) et non le nombre de caractères (qui donnerait 4 avec ta solution).
La solution n°2 de Jocelyn (en réponse plus haut dans ce fil) réponds exactement à ce qu'il me fallait.
Bonne journée.
 

Victor21

XLDnaute Barbatruc
Supporter XLD
Re, Philippe.

J'eusse été surpris que l'ami Jocelyn -bonjour, l'ami :) -ne répondît pas à votre problème.
Ma proposition (image et colonne D du fichier que j'avais joint) consiste à renvoyer directement un nombre (7801), s'affichant comme un texte (Nb de lignes traitées : 7801).
Le nombre de caractères en colonne F ne servait qu'à vous montrer que ce qui est affiché dans une cellule peut être différent de ce qu'elle contient.
 

Staple1600

XLDnaute Barbatruc
Bonsoir à tous

J'ai surement pas tout compris
Mais si en A1, on a: Nbre de lignes traitées : 7 801
Cette formule en B1: =1*STXT(A1;CHERCHE(": ";A1)+2;9^9) renvoie 7801, non ?
 

Staple1600

XLDnaute Barbatruc
Re

Dans ce cas, en empruntant un chouia à Jocelyn ;)
=SUBSTITUE(STXT(A1;CHERCHE(": ";A1)+2;9^9);CAR(160);"")*1
 

Discussions similaires


Haut Bas