Cohérence en fonction de trois colonnes VBA

moussoni

XLDnaute Nouveau
Bonjour à tous !

J'ai un soucis en VBA ; je souhaiterai implémenter sous VBA une fonction Excel qui me permet de contrôler la cohérence entre trois colonne :
=SI(NB.SI($A$2:A55;A55)=NB.SI.ENS($A$2:A55;A55;$G$2:G55;B55);"OK";"nonOK") dans la colonne H
En voilà l'exemple !!!

upload_2019-1-22_11-37-23.png

La fonction compare pour une référence (qui peut être en doublon) en colonne A la cohérence de son emplacement entre la colonne G et B si il y a cohérence la fonction renvoie Ok, nonOK sinon.
Si vous avez des pistes ou des conseils, je suis preneur :)

Merci beaucoup !
 

Yoyo01000

XLDnaute Occasionnel
Bonjour, essaies avec ce code :
VB:
Sub Macro1()

    Range("H2").FormulaR1C1 = _
        "=IF(COUNTIF(R2C1:RC[-7],RC[-7])=COUNTIFS(R2C1:RC[-7],RC[-7],R2C7:RC[-1],RC[-6]),""OK"",""nonOK"")"
    Range("H2").Resize(100).FillDown
 
End Sub
le (100) après Resize est le nombre de cellules à la verticale en dessous de H2 dans la colonne H où seront la formule : à toi de modifier ce chiffre à ta convenance ;)
 

moussoni

XLDnaute Nouveau
Bonjour, essaies avec ce code :
VB:
Sub Macro1()

    Range("H2").FormulaR1C1 = _
        "=IF(COUNTIF(R2C1:RC[-7],RC[-7])=COUNTIFS(R2C1:RC[-7],RC[-7],R2C7:RC[-1],RC[-6]),""OK"",""nonOK"")"
    Range("H2").Resize(100).FillDown

End Sub
le (100) après Resize est le nombre de cellules à la verticale en dessous de H2 dans la colonne H où seront la formule : à toi de modifier ce chiffre à ta convenance ;)
Merci beaucoup Yoyo01000 cela marche super bien
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas