Code postaux et villes

stapsounet

XLDnaute Junior
Bonjour,

Quelqu'un aurait-il un système pour qu'en fonction du code postal saisi, excel me propose les villes y répondantsous forme de liste?

J'ai la liste des communes de France avec leurs code postaux sur une feuille, mais ceux-ci ne sont pas des valeurs uniques!
Donc l'usage de la fonction =RECHERCHEV() dans mon autre feuille ne marche pas. Cela donne la ville du premier code postal rencontrer répondant au critère.

Merci d'avance de vos réponse...:D
 

Baside

XLDnaute Impliqué
Re : Code postaux et villes

Bonjour le Forum,

A adapter en fonction de ton fichier.

Amicalement, Hervé.
 

Pièces jointes

  • Code postal.xls
    43 KB · Affichages: 8 426
  • Code postal.xls
    43 KB · Affichages: 8 185
  • Code postal.xls
    43 KB · Affichages: 8 240

Monique

Nous a quitté
Repose en paix
Re : Code postaux et villes

Bonjour,

Par formules

Sous forme de liste (Formule matricielle, à valider par ctrl, maj et entrée)

mais ça risque d'être lent s'il y a toutes les communes de France

ou bien par liste de validation (Données - Validation)
 

Pièces jointes

  • CodePostalStapsounet.zip
    4.9 KB · Affichages: 3 757

stapsounet

XLDnaute Junior
Re : Code postaux et villes

Merci de vos réponses si rapides...

Monique, c'est exactement ça que je cherchais...

Mais j'avoue être dépassé.Pourrais-tu m'expliquer comment tu as fait que je puisse le refaire moi même?

C'est la colonne H qui m'intéresse: je saisis mon code en H2 et il me donne la liste des possibilité en H3 (génial!!)

merci:D
 

Monique

Nous a quitté
Repose en paix
Re : Code postaux et villes

Re,

En fait, la liste de validation en H3 contient la même chose que la plage F4:F15

La formule est la même :
=DECALER(Prim;EQUIV(H2;Cp;0);;NB.SI(Cp;H2))

Ou bien on la met dans la feuille et on a une liste
ou bien on la met dans "Données - Validation" et on a un choix

DECALER(Réf ; nb de lignes ; nb de colonnes ; Hauteur ; Largeur)

DECALER(1ère cellule au-dessus de la liste des communes; nb de lignes vers le bas : EQUIV(H2; liste des communes;0); 0 colonne donc omis; Hauteur : NB.SI(Cp;H27); Largeur 1 colonne donc omis)

Le format conditionnel :
si on modifie le code postal, la commune choisie précédemment ne correspond pas forcément et il faut donc faire un autre choix.
En attendant un nouveau choix, fond et police ont la même couleur.
 

benlecanard

XLDnaute Junior
Re : Code postaux et villes

Bonjour
sur un sujet très proche pourriez-vous m'aider svp?

Je souhaite faire une vérification sur le code postal et la ville.
La rechercheV ne semble pas pouvoir m'aider car ce que je cherche à vérifier,c'est l'association des 2
(Par exemple 75000 Marseille, ce n'est pas bon)

Merci d'avance
 

Pièces jointes

  • Verif CP-Ville.xls
    16.5 KB · Affichages: 1 561

Tibo

XLDnaute Barbatruc
Re : Code postaux et villes

Bonjour,

Une approche avec une formule matricielle en E2 :

Code:
=SI(ESTNUM(EQUIV(B2&C2;CodesPostaux!$B$2:$B$50&CodesPostaux!$A$2:$A$50;0));"ok";"pas ko")

Formule à valider par CTRL + MAJ + ENTREE

à recopier vers le bas

@+
 

benlecanard

XLDnaute Junior
Re : Code postaux et villes

merci mais cela ne fonctionne pas :(

Ai traduit en anglais et modifié car je pense qu'il fallait comprendre la concaténation de la col B et C (et non A), non?
Pourquoi y a t il une verification si c'est un nombre? (Je suis obligé de rentrer les codes postaux comme du texte pour éviter de perdre les 0 du début)

=IF(MATCH(B3&C3;CodesPostaux!$B$2:$B$50&CodesPostaux!$C$2:$C$50;0);"ok";"pas ko")
 

Tibo

XLDnaute Barbatruc
Re : Code postaux et villes

re,

Je te joins le fichier avec la formule, ce qui permettra la traduction automatique dans ta version.

Ne pas oublier qu'il s'agit d'une formule matricielle (CTRL + MAJ + ENTREE)

Regarde et dis nous

@+
 

Pièces jointes

  • ben_le_canard.zip
    3.1 KB · Affichages: 517

Tibo

XLDnaute Barbatruc
Re : Code postaux et villes

re,

La fonction EQUIV retourne le rang de la donnée cherchée.

Si la donnée est trouvée, elle renvoie un chiffre (son rang) donc une valeur numérique (CQFD)

Si la donnée n'est pas trouvée, elle renvoie un message d'erreur

D'où la formule : si le résultat de la formule est numérique, c'est que la donnée cherchée existe.

Voilou

@+
 

benlecanard

XLDnaute Junior
Re : Code postaux et villes

Encore merci!

A noter que cela fonctionne bien mais que je ne peux pas trop l'utiliser à grande échelle
[Sur un grand nombre de données(fichier client vs base des CP/ville de France par exemple) Excel met beaucoup de temps ou plante... A noter que ca semble aller beaucoup plus vite avec le fichier des CP ouvert]
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
298 970
Messages
1 973 247
Membres
204 017
dernier inscrit
hyann