Office 365 Chiffres d'affaires à répartir mensuellement sur 0 à 12 mois entre deux dates

kyoshoo

XLDnaute Nouveau
Supporter XLD
Bonjour,
Pourriez-vous m'aider sur ce petit casse tête

j'ai un tableau Excel avec :

CA = Chiffre d'affaire (C)
Date de début (D)
date de fin (E)
Nombre de jours de prestations (G)
Nombre de mois entre deux dates pour les cellules non vides de mon tableau (G)
=SI(G2="";"";DATEDIF(D2;E2;"m"))

Revenu mensuel moyen que je calcul (J)
=SI(ET(I2<=0);B2*G2/1;SI(ET(I2="");"";C2/I2))

maintenant je cherche à répartir le revenu moyen sur l'année en fonction de la date de début et date de fin
janvier 2019 (L)

=SI(ET($L$1>=$D2;$L$1<=$E2);$J2;"")

Globalement cela fonctionne Mais j'ai plusieurs coquille dans la répartition :
j'ai fait une colonne contrôle en (K)
=SI(ET(J2="");"";SI(ET(SOMME(L2:AJ2)=C2);"OK";"Contrôle"))

les erreurs de contrôle sont :
- soit il m’affiche un mois en trop ou en moins
- soit je n'ai rien qui s'affiche car il ne semble pas pouvoir établir la vérification entre la date de début et de fin sur des prestations ou le nombre de mois est de 0 car la date de début et fin est sur le même mois; à noter que parfois cela fonctionne.
 

Fichiers joints

Dernière édition:

Nairolf

XLDnaute Impliqué
Salut kyoshoo, salut le forum,

Est-ce que ça correspond à ton besoin si tu remplaces les formules en I par :
Code:
=SI(G2="";"";ANNEE('Monthly statement R '!E2)*12+MOIS('Monthly statement R '!E2)-ANNEE('Monthly statement R '!D2)*12-MOIS('Monthly statement R '!D2)+1)
et les formules à partir de la colonne L par :
Code:
=SI(ET(L$1>=DATE(ANNEE($D2);MOIS($D2);1);L$1<=DATE(ANNEE($E2);MOIS($E2);1));$J2;"")
 

kyoshoo

XLDnaute Nouveau
Supporter XLD
Hello,

Je n'ai pas pu m'empêcher de faire un test parfait.
je regarderai demain tranquillement au travail pour comprendre.
Merci beaucoup !
 

merinos

XLDnaute Occasionnel
Salut @kyoshoo ,

J'ai réalisé il y eu une methode pour repartir le chiffre d'affaire sur le temps ... et ce dans un PVT.

Ma réponse

La différence entre les 2 question est que tu dispose du CA total, alors que le question était avec un CA par jour.
 

Discussions similaires


Haut Bas