XL 2010 Calendrier de mouvement

zizou721

XLDnaute Nouveau
Bonjour,
À partir de la cellule A1 (quelque soit l'année (futur voir même passé), je souhaite actualiser le calendrier et mettre à jour les onglets mois (de janvier à décembre) ceci en grisant les lignes samedi/dimanche. (Voir fichier)
Par avance, je vous remercie beaucoup.
Cordialement,
Zizou
 

Pièces jointes

  • Tableau_Mouvement.xlsx
    54.7 KB · Affichages: 13

chris

XLDnaute Barbatruc
Bonjour

Si A1 de Calendrier doit conditionner les dates de calendrier, remplacer par la formule
VB:
=SI(DATE($A$1;LIGNE(A1);COLONNE(A1))>FIN.MOIS(DATEVAL($A3&$A$1);0);"";DATE($A$1;LIGNE(A1);COLONNE(A1)))
à étendre en bas et à droite

Mais à part l'année je ne vois pas l’intérêt de cet onglet pour les autres

Dans les onglets en A3 à étendre en dessous
Code:
=DATEVAL(LIGNE(A1)&$A$1&Calendrier!$A$1)

Pour la MFC, sélectionner les colonnes concernées (de B à ...) sur les lignes 3 à 33
Code:
=ET(JOURSEM($A3;2)>5;$A3<>"")
 

Discussions similaires