XL 2016 calculs par formules ou macros

sev31130

XLDnaute Impliqué
bonsoir

a toutes fins de pouvoir automatiser mes ca&lculs et ne suis pas une lumière est ce que quelqu'un pourrait regarder et me dire ce qui est faisable sur le fichier ci-joint
vous en remerciant par avance
Cordialement
 

Fichiers joints

Dernière édition:

sev31130

XLDnaute Impliqué
Bonjour

c'est juste pour faire remonter ma demande que je viens de nouveau ce matin demander de l'aide s'il vous plait
Merci
 

sev31130

XLDnaute Impliqué
bonjour

Si une partie de ce que j'ai besoin pouvait m'être accorder ce serait toujours cela de gagner
par avance merci
Cordialement
Yves
 

Fichiers joints

Dernière édition:

youky(BJ)

XLDnaute Barbatruc
Bonjour Sev,
J'ai pris le temps de consulter le fichier et de comprendre comment il fonctionne
mais bon j'ai abandonné impossible d'en comprendre le raisonnement.
Je me suis sentis largué et je pense que je ne dois pas être le seul.

Bruno
 

sev31130

XLDnaute Impliqué
Je mets le fichier je viens de rajouter deux feuilles pour créer le fonctionnement justement et si au moins vous pouviez me donner les deux ou 3 formules que je ne sais pas faire
par avance merci
 

Fichiers joints

Dernière édition:

sev31130

XLDnaute Impliqué
merci juste une petite rectif svp
mille merci c'est bien ce que je voulais mais je ne sais pas faire et je me suis mal exprimé
la derniére ligne c etait celle de contole pour voir si mes calculs étaient juste
voir note sur feuille
Encore mille merci
 

Fichiers joints

sev31130

XLDnaute Impliqué
a l'attention de BRUNO (merci) ou d'une personne qui veut bien me faire la modif svp
Bonjour

En effet j'ai fais une erreur de langage quand j'ai dit "dernière ligne " c'est "dernière journée"
si vous pouviez regarder svp por me faire la modif sur la macro
par avance merci
Cordialement
 

Fichiers joints

youky(BJ)

XLDnaute Barbatruc
hello,
La formule en onglet 01!H10
=NB.SI(H13:H43;"np")
ou si faut faire moins les np - ni
=NB.SI(H13:H43;"np")-NB.SI(H13:H43;"ni")
La macro ci dessous mets des zéro à la place des cellules rouges
Si j'ai compris car toujours mal expliqué.
Bruno
VB:
Sub G_et_P_en_01()
lig = Application.CountIf(Sheets("G").[H4:H34], ">-1") + 3
Sheets("01").[H3:AA3].Value = Sheets("G").Range("H" & lig & ":AA" & lig).Value
For k = 29 To 48
If Sheets("G").Cells(lig, k) = 1 Then Sheets("01").Cells(3, k - 21) = 0
Next
lig = Application.CountIf(Sheets("P").[H4:H34], ">-1") + 3
Sheets("01").[H4:AA4].Value = Sheets("P").Range("H" & lig & ":AA" & lig).Value
For k = 29 To 48
If Sheets("P").Cells(lig, k) = 1 Then Sheets("01").Cells(4, k - 21) = 0
Next
End Sub
 

sev31130

XLDnaute Impliqué
j avais pas compris ce que tu m' avais marquer tu vois je crois que c'est l'age
en effet c'est une lecture de toutes les valeurs de la ligne et ou il y a des cellules rouges
prendre la valeur de la cellule
mais c'est pas grave je ne vais pas t'embeter plus longtemps
tu m'as déjà fais grandir d'un grand pas
merci
 
Dernière édition:

sev31130

XLDnaute Impliqué
bonjour

je reviens vers Youki pour deux questions ensuite je ne t'embeterais plus promis
1) si possible La macro ci dessous mets des zéro à la place des cellules rouges (non mettre la valeur de la cellule sans tenir comte de la couleur )
2) si je change tous les 01 en 02 pour la feuille 02 comme ci-dessous la macro ne fonctionne pas, car je voudrais pouvoir faire les changements et
m'en servir tout le temps en changeant de feuille en fin de mois (voir ci-dessous et me dire mon erreur ) par avance merci (je viens de voir que c'est le bouton qui est spécifique est ce que j'ai une solution pour me servir du bouton ou je lance la macro directement ? )

Sub G_et_P_en_02()
lig = Application.CountIf(Sheets("G").[H4:H34], ">-1") + 3
Sheets("02").[H3:AA3].Value = Sheets("G").Range("H" & lig & ":AA" & lig).Value
For k = 29 To 48
If Sheets("G").Cells(lig, k) = 1 Then Sheets("02").Cells(3, k - 21) = 0
Next
lig = Application.CountIf(Sheets("P").[H4:H34], ">-1") + 3
Sheets("02").[H4:AA4].Value = Sheets("P").Range("H" & lig & ":AA" & lig).Value
For k = 29 To 48
If Sheets("P").Cells(lig, k) = 1 Then Sheets("02").Cells(4, k - 21) = 0
Next
End Sub

Merci
 

youky(BJ)

XLDnaute Barbatruc
Voici avec macro modifiée.
Nom macro modifié aussi
Indication dans le fichier pour le bouton et affecter une macro.
Un message demande le Nom de l'onglet 01 02 . . . . 12
Bruno
 

Fichiers joints

sev31130

XLDnaute Impliqué
bonjour Bruno
c'est gentil de votre part mais vous avez travailler sur le premier fichier ou la macro copie la derniére ligne et non pas la dernière lgne
du bloc H3:AA04 aussi je vous joins le fichier avec l'explications
merci de voir svp
merci encore mille fois
Cordialement
Yves
 

Fichiers joints

youky(BJ)

XLDnaute Barbatruc
Oui je me mélange les pédales, hihi!
voici rectifié
Bruno
VB:
Sub G_et_P_en_onglet()
On Error Resume Next
onglet = InputBox("Indiquer le nom de l'onglet", "NOM ONGLET")
If onglet = "" Then Exit Sub
Sheets(onglet).Activate
If Err <> 0 Then MsgBox "Nom d'onglet Inconnu !": Exit Sub
lig = Application.CountIf(Sheets("G").[H4:H34], ">-1") + 3
Sheets(onglet).[H3:AA3].Value = Sheets("G").Range("H" & lig & ":AA" & lig).Value
lig = Application.CountIf(Sheets("P").[H4:H34], ">-1") + 3
Sheets(onglet).[H4:AA4].Value = Sheets("P").Range("H" & lig & ":AA" & lig).Value
End Sub
 

Discussions similaires


Haut Bas