XL 2019 Calculer une occurence en fonction d'une date supérieur à une autre

azora

XLDnaute Nouveau
Bonjour ,

Je dispose d'un tableau avec une liste de prénom qui peuvent apparaitre plusieurs fois (il s'agit de la même personne)
J'ai une date d'anniversaire en face de chaques prénoms
Je dispose ensuite d'une date de début à l'école
Puis un nombre de parts

On imagine donc comme suit :

PrenomA 12/10/1993 09/12/2001 4
PrenomB 01/03/1995 03/04/1992 5
PrenomA 12/10/1993 05/12/1997 1

L'idée est de calculer le nombre de part si et seulement si la date d'anniversaire est > à la date de début.

Par exemple pour prénom A on aurait 5 car 12/10/1993 > aux 2 dates présente dans le tableau.
Il a eu 4+1 parts .
Prénom B 0 car 01/03/1995 < aux 2 autres dates.

Une âme charitable svp ?

Merci
 
Dernière édition:

azora

XLDnaute Nouveau
Bonjour à tous,

A essayer en "I2"
VB:
=SOMME.SI.ENS($D$2:$D$15;$A$2:$A$15;$H2;$C$2:$C$15;">"&$B$2:$B$15)
Copier vers le bas

JHA
Merci infiniment !!!

Autre point
J'aimerai sur ce même fichier
Compter le nombre d'occurence si et seulement si la date d'anniversaire est supérieur à la date de début ?
Si on reprends mon exemple plus haut :

PrenomA 12/10/1993 09/12/2001 4
PrenomB 01/03/1995 03/04/1992 5
PrenomA 12/10/1993 05/12/1997 1

On aurait 2 pour le prénom A
et 0 pour le prénom B

Merci encore
 

Statistiques des forums

Discussions
293 048
Messages
1 928 125
Membres
183 855
dernier inscrit
safelhr