XL 2016 Calculer les non vide en fonction d'une autre colonne

CR1910

XLDnaute Nouveau
Bonjour,

Je cherche une formule me permettant de calculer les non vide de ma colonne B en fonction de colonne A si cette dernière contient un mot spécifique.
Exemple : si colonne A contient "Produit Marketing" alors calculer les non-vide de la colonne B de la même ligne. J'aimerai également le faire sur les autres colonnes C,D toujours en fonction de colonne A.

C'est sans doute une formule simple mais je n'arrives pas à trouver une formule qui fonctionne correctement. Ci joint un fichier exemple

Merci beaucoup de votre aide ! :)
 

Fichiers joints

eriiiic

XLDnaute Barbatruc
Bonjour,

calculer = compter ?
VB:
=NB.SI.ENS(A4:A21;"Produit Marketing";B4:B21;"<>")
faire 3 fois pour 3 colonnes
eric
 

CR1910

XLDnaute Nouveau
Bonjour,

calculer = compter ?
VB:
=NB.SI.ENS(A4:A21;"Produit Marketing";B4:B21;"<>")
faire 3 fois pour 3 colonnes
eric

Oui désolé le bon terme était compter plutôt que calculer. Merci beaucoup pour la formule cela fonctionne ! :)
Bonne journée
 

CR1910

XLDnaute Nouveau
Bonjour à tous,

Formule à essayer exemple en "B23"
VB:
=NB.SI.ENS($A$4:$A$21;"Produit Marketing";B$4:B$21;"<>"&"")
copier vers la droite

JHA

Merci, formule également très pratique, j'ai une vingtaine de colonne... ;)
 

Discussions similaires


Haut Bas