XL 2019 Calculer cadence sur excel pour planning de production

Vanhoove

XLDnaute Nouveau
Bonjour,



J'ai un problème de calcul de cadence, voici mes contraintes :

Horaire de 7h à 15h , et possibilité de deux équipes réparties de 6-14h / 14-22h

Cadences et quantités différentes selon les produits (je viens chercher les information de cadence dans un onglet "base" où j'ai de code article avec la cadence associée )

J'aimerais connaitre la date de fin de production selon les contraintes si dessus, sauf que si un of commence avant 15 h mais ne peut se terminer le jour même, ils continuent de comptabiliser durant une période non travaillée et une fois la journée terminée, le compteur remis à 0, ça ne s'incrémente plus.

Il prend en compte les WE et jours fériés aussi....



Merci pour votre aide

(Je n'arrive pas à joindre mon fichier)

Formule en cadence OF : qté*7:00:00/cadence

à côté de qté of, c'est la quantité cumulée

Colonne 0 : =SI(H2<1200;SOMME(H2+G3);SOMME(H2*0))

Première colonne de date =SI(K2=J2;J2;K2)

Deuxième colonne date : =SI(H3<1200;J3;SOMME(J3+1))





ArticleQtéDate de fabDélaiCADENCE OFcadenceqté of0,027/05/2021
51A2000,026/04/202117:20:0060,002000,002000,00027/05/202128/05/2021
07:00:00​
5163,027/04/202100:22:031200,0063,002063,00028/05/202129/05/2021
07:00:00​
517A48,027/04/202100:40:19500,0048,002111,00029/05/202130/05/2021
07:00:00​
5191A48,025/05/202101:07:12300,0048,002159,00030/05/202131/05/2021
07:00:00​
5110010,030/04/202100:14:00300,0010,002169,00031/05/202101/06/2021
07:00:00​
51300B336,014/04/202123:31:12100,00336,002505,00001/06/202102/06/2021
07:00:00​
 

Discussions similaires

Réponses
17
Affichages
2 K
  • Question
Microsoft 365 Planning
Réponses
2
Affichages
962

Statistiques des forums

Discussions
298 812
Messages
1 971 978
Membres
203 566
dernier inscrit
excel-92