Calcul Rang avec formule

Alyrio

XLDnaute Nouveau
Bonjour,
J'ai un tableau a remplir avec des rangs qui sont des nombres correspondent tout simplement
au nombre de fois que des noms apparaissent dans mon tableau. Ces nombres doivent augmenter au fur et a mesure qu'un même nom est trouvé.
Je me demandais si c'était possible de le faire avec des formules.

Par la suite ces rangs sous forme de nombre deviennent des lettres.
Mais pour cette partie je me débrouille.
Je vous envoie un classeur dans lequel se trouve le tableau en question et la colonne a remplir en bleu dans le fichier (colonne J).

Merci pour votre aide.
 

Fichiers joints

tototiti2008

XLDnaute Barbatruc
Re : Calcul Rang avec formule

Re,

en E3 :

Code:
=NB.SI($B$2:B3;B3)
à recopier vers le bas

pour les lettre je te laisse faire, je n'ai rien compris
 

Habitude

XLDnaute Accro
Re : Calcul Rang avec formule

Regarde du coté de la fonction RANG

@tototiti2008
J'ai pensé comme toi dès le départ mais il utilise déjà cette formule en colonne D.
 

Tibo

XLDnaute Barbatruc
Re : Calcul Rang avec formule

Bonjour,

en E3, tu peux tester cette formule :

Code:
=NB.SI($B$3:$B3;$B3)
à recopier vers le bas

@+

Edit : Oups ! un peu en retard sur le coup ...

@+

Edit :

habitude,

La formule proposée par tototiti (et moi-même) n'est pas exactement la même que celle de la colonne D. La formule que nous avons proposée fait référence à une définition de la colonne dynamique ($B3 : figé - B3 : non figé, donc évolutif lors de la recopie)
 
Dernière édition:

Habitude

XLDnaute Accro
Re : Calcul Rang avec formule

Bonjour,

en E3, tu peux tester cette formule :

Code:
=NB.SI($B$3:$B3;$B3)
à recopier vers le bas

@+

Edit : Oups ! un peu en retard sur le coup ...

@+

Edit :

habitude,

La formule proposée par tototiti (et moi-même) n'est pas exactement la même que celle de la colonne D. La formule que nous avons proposée fait référence à une définition de la colonne dynamique ($B3 : figé - B3 : non figé, donc évolutif lors de la recopie)
D'accord mais je n'y vois pas la logique applicable
 

Alyrio

XLDnaute Nouveau
Re : Calcul Rang avec formule

pfffff Incroyable Trop fort !!!
je confirme donc
Code:
=NB.SI($B$2:B3;B3)
Cela correspond effectivement à ma demande.
Mille merci a tous.
Merci @ tototiti2008 et aux autres d'avoir participé.
Je vous souhaite un bon WE à tous.
Merci encore ! Youpi !
 
Dernière édition:

tototiti2008

XLDnaute Barbatruc
Re : Calcul Rang avec formule

Bonjour Tibo, Bonjour Habitude,
Re,

D'accord mais je n'y vois pas la logique applicable
Pour être franc, moi non plus pas vraiment : c'est le nombre de fois où le prénom est apparu dans la liste jusque là...
 

Discussions similaires


Haut Bas