Calcul pourcentage de jours par mois avec 2 dates saisies

Lili189

XLDnaute Junior
Bonjour,
je suis secrétaire comptable et je recherche une manière avec excel de calculer le pourcentage de jours par mois en fonction des contrats des employés.
Je vous explique :
J'ai mes 2 dates de contrats : exemple => un employé du 15 janvier 2012 au 20 mars 2012.
Je dois remplir un tableau avec le pourcentage de jours qu'il fait dans le mois.
par exemple :
du 15 janvier au 31 janvier = 0.52
du 1er février au 29 février = 1
du 1er mars au 20 mars = 0.64
JANV-FEV-MAR
0.52- 1 - 0.64
Je souhaiterais avoir une formule pour que mon tableau se remplisse tout seul après la saisie des 2 dates.
voici un screen de ce que j'aimerais


Visionneuse images - Noelshack

Est-ce possible ?
merci d'avance à qui m'aidera car je planche dessus depuis quelques jours ^^' et cela me faciliterait grandement la tâche :)

Aurélie
 
Dernière édition:

Modeste geedee

XLDnaute Barbatruc
Re : Calcul pourcentage de jours par mois avec 2 dates saisies

Bonsour®
je recherche une manière avec excel de calculer le pourcentage de jours par mois en fonction des contrats des employés.
Je vous explique :
J'ai mes 2 dates de contrats : exemple => un employé du 15 janvier 2012 au 20 mars 2012.
Je dois remplir un tableau avec le pourcentage de jours qu'il fait dans le mois.
par exemple :
du 15 janvier au 31 janvier = 0.52
du 1er février au 29 février = 1
du 1er mars au 20 mars = 0.64
JANV-FEV-MAR
0.52- 1 - 0.64
Je souhaiterais avoir une formule pour que mon tableau se remplisse tout seul après la saisie des 2 dates.


voir la pièce jointe :
 

Pièces jointes

  • lili189.xls
    60 KB · Affichages: 176
  • lili189.xls
    60 KB · Affichages: 184
  • lili189.xls
    60 KB · Affichages: 154

Lili189

XLDnaute Junior
Re : Calcul pourcentage de jours par mois avec 2 dates saisies

merci beaucoup de vos réponses ! ça marche bien.

Seul petit soucis lorsque je veux mettre un employé qui est là toute l'année, je mets du 01/01/12 au 31/12/12, ça me met bien des 1 partout sauf pour janvier qui a 0.97.

Janvier se met à 1 que si je mets 00/01/12 comme date de départ.

Vous avez une idée de comment corriger cela ? :)
 

ERIC S

XLDnaute Barbatruc
Re : Calcul pourcentage de jours par mois avec 2 dates saisies

re

il y avait je pense plusieurs cas litigieux

je te propose de faire en 2 fois

en C2 et tu tires
=SI($B2<$A2;"erreur date fin";SI($A2<D$1;SI($B2>=C$1;MIN($B2+1;D$1)-MAX($A2;C$1);0);0))

tu dois voir le nombre de jours, teste tous tes cas particuliers (même mois, datefin<datesup...)

si tout est ok, tu rajoutes le diviseur pour obtenir
=SI($B2<$A2;"erreur date fin";SI($A2<D$1;SI($B2>=C$1;MIN($B2+1;D$1)-MAX($A2;C$1);0);0))/(D$1-C$1)
 

Modeste geedee

XLDnaute Barbatruc
Re : Calcul pourcentage de jours par mois avec 2 dates saisies

Seul petit soucis lorsque je veux mettre un employé qui est là toute l'année, je mets du 01/01/12 au 31/12/12, ça me met bien des 1 partout sauf pour janvier qui a 0.97.

Janvier se met à 1 que si je mets 00/01/12 comme date de départ.

Vous avez une idée de comment corriger cela ? :)

oupsss !!!
en effet nombreuses anomalies
ci joint version revue et corrigée ...
 

Pièces jointes

  • lili189.xls
    57.5 KB · Affichages: 103
  • lili189.xls
    57.5 KB · Affichages: 104
  • lili189.xls
    57.5 KB · Affichages: 118

mapomme

XLDnaute Barbatruc
Supporter XLD
Re : Calcul pourcentage de jours par mois avec 2 dates saisies

Bonjour Lili189,

Avec une formule matricielle en C2 à tirer jusqu'à N2 puis vers le bas:
Code:
=SOMMEPROD(--($A2+LIGNE(INDIRECT("1:" & ($B2-$A2+1)))-1>=DATE(ANNEE(C$1);MOIS(C$1);1)) * ($A2+LIGNE(INDIRECT("1:" & ($B2-$A2+1)))-1<=DATE(ANNEE(C$1);MOIS(C$1)+1;1)-1))/JOUR(DATE(ANNEE(C$1);MOIS(C$1)+1;1)-1)

Formule matricielle: Elle doit être validée par la combinaison des touches Ctrl+Maj+Entrée au lieu de la seule touche Entrée comme une formule classique.
Si la validation matricielle est correcte, alors Excel entoure la formule d'accolades {=.......}.
Chaque fois que cette formule sera modifiée, la validation devra se faire par Ctrl+Maj+Entrée. Les accolades apparaissent à la validation et ne doivent pas être saisies au clavier.
 

Pièces jointes

  • pourcentage de jours par mois v1.xls
    68.5 KB · Affichages: 133

Lili189

XLDnaute Junior
Re : Calcul pourcentage de jours par mois avec 2 dates saisies

Re-bonjour,

j'ai une nouvelle question pour mon tableau.

J'aimerais une liste de validation dans une cellule avec janvier, février, mars avril etc... et que cela me calcul la somme jusqu'au mois sélectionné.

Voici mon fichier excel en PJ.

Le problème quand je fais une liste de validation, cela ne me fait pas une somme mais j'ai des résultats très bizarres.

j'ai pourtant fait la formule : =SOMME(DECALER(L3;0;0;1;EQUIV($Y$2;2:2;0)))

mais je n'obtiens pas 2,55 quand je sélectionne Mars par exemple.

pourriez vous m'éclairer ? :rolleyes:
 

Pièces jointes

  • Calcul par mois.xls
    15 KB · Affichages: 104

Membres actuellement en ligne

Statistiques des forums

Discussions
291 805
Messages
1 918 119
Membres
179 932
dernier inscrit
Starsat1200
Haut Bas