XL 2016 calcul des heures de location

dindin

XLDnaute Occasionnel
Bonjour le forum,
depuis qq jours je bloque sur le calcul des heures (addition et soustraction) dans des textbox.
le formulaire propose à l'utilisateur de sélectionner jusqu'à 4 dates de location d'une salle :
1620979292850.png

selon le choix, la date du jour s'affiche automatiquement
les heures dans des combo de 07h du matin à minuit step 00:30

- le premier souci c'est le nombre d'heures de réservation si je sélectionne minuit en heure de fin (il me fait le calcul inversement voir photo : -07:00)

- le total des heures si je sélectionne 2 dates et plus ne fonctionne pas en rouge sur la photo:

1620979613589.png


- mon gros souci aussi est la calcul des heures de chauffage si la date sélectionnée est comprise entre 01 oct et 30 avril .
avec une formule ça fonctionne très bien :
VB:
=SI(ET(D26>=Début_Chauffage;D26<=fin_Chauffage);Y26;"0")
mais je n'arrive à la traduire en vba.
j'aurais besoin de votre aide car malgré mes essais je bloque depuis quelque jours.
et je n'arrive pas à avancer.
je vous joint le fichier après suppression des infos
 

Pièces jointes

  • 1620979182399.png
    1620979182399.png
    33.1 KB · Affichages: 19
  • 1620979556289.png
    1620979556289.png
    16.2 KB · Affichages: 7
  • Gestion des salles 2021.xlsm
    51.6 KB · Affichages: 16

ChTi160

XLDnaute Barbatruc
Re
ton fichier
au quel j'ai fais quelques Modifs
1° remplacement des OptionButton par des CheckBox :
2° Codes simplifiés
3° suppression des formats avec "€" et ajout de Label avec le sigle "€"
etc etc
tu regardes et tu en fais ce que tu veux Lol
jean marie
 

Pièces jointes

  • Gestion des salles 2021 Chti160-2.xlsm
    718.9 KB · Affichages: 2
Dernière édition:

Statistiques des forums

Discussions
290 755
Messages
1 910 210
Membres
176 539
dernier inscrit
altheamain
Haut Bas