Calcul amplitude horaire

tipoone

XLDnaute Nouveau
Bonjour,

Je me permets d'ouvrir une nouvelle conversation car je n'ai pas trouvé de réponse dans le forum (en espérant avoir bien cherché).
Voici mon problème :
Une personne travaille de 20h00 à 05h00. Je cherche une formule qui me me calculerait dans une première cellule le nombre d'heures travaillées et dans une deuxième cellule le nombre d'heures travaillées entre 00:00 et 04:00.
Soit 9 heures travaillées et 4 heures entre 00:00 et 04:00 pour mon exemple.
En sachant que la personne peut très bien avoir comme horaire 17h00/ 02h00. Ce qui donnerait 9h de travail total et 2h entre 00:00 et 04:00.
Merci d'avance pour votre aide.
Bon week-end à tous !
 

NicolasL

XLDnaute Nouveau
Ta question recoupe un peu la mienne, va voir la PJ du fil "ajouter une semaine paire et une semaine impaire...", en fouillant dans les formules qui la composent tu va peut être trouver ton bonheur ;) (en attendant qu'un plus calé que moi réponde :p )
 

ROGER2327

XLDnaute Barbatruc
Bonsoir à tous.

Un autre essai.

ℝOGER2327
#8375


Lundi 23 Haha 144 (Chapeau de Bosse-de-Nage - fête Suprême Tierce)
7 Brumaire An CCXXV, 7,9372h - figue
2016-W43-5T19:02:57Z
 

Fichiers joints

tipoone

XLDnaute Nouveau
Bonjour Roger2327,

Pourrais-tu m'expliquer la formule que tu as utilisée ? j'ai besoin de faire ressortir le nombre d'heure qu'il y a entre 21:00 et 6:00 mais je n'arrive pas a comprendre la formule ... hihi
Merci à toi
 

ROGER2327

XLDnaute Barbatruc
Re...

De minuit à quatre heures le lendemain ou de vingt et une heures à six heures le lendemain ?
Ou de zéro heure à six heures et de vingt et une heures à six heures le lendemain et encore de vingt et une heures à minuit le lendemain ?​

Voyez si le classeur joint apporte quelque chose...​

Bonne soirée.


ℝOGER2327
#8381


Lundi 2 As 144 (Sainte Rrose Sélavy, héroïne - fête Suprême Quarte)
14 Brumaire An CCXXV, 6,7874h - endive
2016-W44-5T16:17:23Z
 

Fichiers joints

JBARBE

XLDnaute Barbatruc
Bonsoir à tous,

Excusez-moi de rajouter ma sauce à vos subtiles recettes !
Peut-être également ceci !
bonne soirée !
 

Fichiers joints

ROGER2327

XLDnaute Barbatruc
Re...

Bonsoir à tous,

Excusez-moi de rajouter ma sauce à vos subtiles recettes !
Peut-être également ceci !
bonne soirée !
Ça marche souvent, mais pas toujours. Exemple : Début 2 h, fin 1 h (le lendemain). Vous obtenez 1h dans le créneau minuit / quatre heures. Or il y a en réalité deux heures de 2 h à 4 h en début de poste, puis une heure entre minuit et 1 h en fin de poste. Total : trois heures.
D'accord, un poste de vingt-trois heures, c'est beaucoup.
Mais avec les saloperies législatives qui viennent de nous tomber sur la gueule cette année, p't'être que ça peut servir d'ici peu...

Pour obtenir cela, je propose :

=SI(NB.SI(B2:C2;"");"";ARRONDI(MIN(1/6;C2+(C2<B2))-MIN(1/6;B2)+MAX(1;MIN(7/6;C2+(C2<B2)))-1;6))
(À tester dans tous les sens : il y a peut-être d'autres cas vicieux...)

Remarquez que votre formule se simplifie aisément en

=SI(OU(B2="";C2="");"";SI(B2<=C2;MIN(1/6;C2)-B2;MIN(1/6;C2)))
(en prime, il n'y a plus d'erreur si, par inadvertance, on a mis la même heure pour le début et la fin.)

Bonne nuit.

ℝOGER2327
#8382


Mardi 3 As 144 (Couronnement de Lord Patchogue, miroitier - fête Suprême Quarte)
15 Brumaire An CCXXV, 0,0993h - dindon
2016-W44-6T00:14:18Z



 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas