XL 2016 Boucle conditions imbriquées

amayas

XLDnaute Nouveau
Bonjour à tous,

Je me tourne à nouveau vers vous pour régler un véritable casse-tête, mon problème est le suivant :
J’essaye de mettre en place une formule ou une boucle qui puisse me permettre d’imbriquer plusieurs conditions et le principe est le suivant :
Trier de Z  A par pf_code
Trier par la suite de Z  A par Fiche (« Pro » « Non Pro »)
Facturer de la manière suivante :
• S’il y a succession de Pro pour le même pf_code : calculer 2403,25*30/360 pour la première ligne pro et mettre à zero les suivantes.
• S’il y a une succession de Non Pro pour le même pf_code : calculer 2403,25*30/360 pour la première ligne pro et mettre à zero les suivantes.
• S’il y a une succession de Pro suivie d’un Non Pro pour le même pf_code : calculer 2403,25*30/360 pour la première ligne pro et mettre à zero les Pro suivantes et calculer 745,84*30/360 pour la Non Pro
• S’il y a une succession de Pro suivie de plusieurs Non Pro pour le même pf_code : calculer 2403,25*30/360 pour la première ligne pro et mettre à zero les Pro suivantes et calculer 745,84*30/360 pour toutes les Non Pro

Naïf comme je suis j’ai essayé avec l’aide de l’enregistreur de Macro d’introduire la formule de conditions imbriquées qui suit : =SI(F22="Pro";$G$2*$D$1/$E$1;SI(F22="Pro"&F21="Pro"&A22=A21;0;SI(F22="Non Pro";$H$2*$D$1/$E$1;SI(F22="Non Pro"&F21="Non Pro"&A22=A21;0;SI(F22="Non Pro"&F21="Pro";$H$2*$D$1/$E$1;SI(F22="Non Pro"&F21="Pro";$H$2*$D$1/$E$1;SI(F22="Non Pro"&F21="Non Pro"&F20="Pro";$H$2*$D$1/$E$1;FAUX))))) et il faut dire qu’elle a ses failles.
Vous trouverez ci joint le classeur concerné.
En vous remerciant par avance.

AMAYAS
 

Pièces jointes

  • Classeur1.xlsm
    37.5 KB · Affichages: 12

sousou

XLDnaute Barbatruc
Bonsoir
J'ai tenté quelque chose, mais pas certain que j'ai bien assimilé les 4 règles que tu demandes.
TU devrai pouvoir modifier facilement ces dernières en analysant ce que je te propose
j'ai mis les résulats dans une colonne spécifiques à modifier en fonction de tes besoins
Module 3 macro debut()
 

Pièces jointes

  • Copie de Classeur1-1.xlsm
    44.2 KB · Affichages: 1

Discussions similaires

Statistiques des forums

Discussions
291 667
Messages
1 916 973
Membres
179 500
dernier inscrit
oximo
Haut Bas