Autres Bonjour au forum

alain.pierrephie

XLDnaute Occasionnel
Bonjour,
J'ai fait une formule classique =SOMMEPROD(($V$3:V100=AH2)*($B$3:B100>=AE2)*($B$3:B100<=AF2)*$X$3:X100)
mais cela me met: #VALEUR!
j'ai pourtant fait cette formule à plusieurs reprise et je n'ai jamais eu de problème. J'ai mis une copie simple (sinon trop gros)
Si quelqu'un a une idée du pourquoi ça ne marche pas !!!
merci a vous

nb: les données viennent d'un userform
 

Pièces jointes

  • Pour exceldown.xlsx
    9.6 KB · Affichages: 23

alain.pierrephie

XLDnaute Occasionnel
re,
Bonjour Victor21 :)

vu ta formule et sans fichier original je pense que ton problème vient de la colonne X qui doit contenir des valeur alpha

tu peux donc essayer de modiifer ta formule de cette façon

VB:
=SOMMEPROD(($V$3:$V$100=AH2)*($B$3:$B$100>=AE2)*($B$3:$B$100<=AF2)*1;$X$3:$X$100)

ou éplucher ta colonne X pour virer les valeur alpha

Cordialement
Qu'appelles tu valeur alpha ?
 

Victor21

XLDnaute Barbatruc
J'obtiens cela en cliquant sur évaluer
Regarde la pièce jointe 1115659
Si vous continuez à évaluer, et scrutez les valeurs (o, vrai, faux), vous tomberez tôt ou tard sur une /des #VALEUR! : ici la 3° valeur de la dernière condition (test), les 95 zéros suivants correspondent aux cellules vides X6:X100
1631701695106.png
 
Dernière édition:

Discussions similaires

Membres actuellement en ligne

Statistiques des forums

Discussions
290 755
Messages
1 910 209
Membres
176 539
dernier inscrit
altheamain
Haut Bas