Autres Bonjour au forum

alain.pierrephie

XLDnaute Occasionnel
Bonjour,
J'ai fait une formule classique =SOMMEPROD(($V$3:V100=AH2)*($B$3:B100>=AE2)*($B$3:B100<=AF2)*$X$3:X100)
mais cela me met: #VALEUR!
j'ai pourtant fait cette formule à plusieurs reprise et je n'ai jamais eu de problème. J'ai mis une copie simple (sinon trop gros)
Si quelqu'un a une idée du pourquoi ça ne marche pas !!!
merci a vous

nb: les données viennent d'un userform
 

Pièces jointes

  • Pour exceldown.xlsx
    9.6 KB · Affichages: 23

alain.pierrephie

XLDnaute Occasionnel
Bonjour
peut-être avec = en tète de formule !!
Bonjour PJ
Qu'est qu'il y aurait avec se signe = ? Sur ma formule il y est. Je n'ignore pas bien entendu qu'avant d'écrire une formule il faut mettre le signe = pour ouvrir une formule. C'est le B-A BA de excel
A moins que vous n'ayez vu quelque chose que je n'ai pas vu.
Merci de vous pencher sur mon souci PJ c'est gentil à vous
 

Jocelyn

XLDnaute Barbatruc
Bonjour Le Forum,
Bonjour alain.pierrephie, pierrejean,

Me voila principalement pour saluer l'ami pierrejean

Ensuite je pense que ce qu'il voulait dire c'est que la formule fonctionne (du moins chez moi)le résultat est de 445 et pas d'affichage valeur

Cordialement

EDIT : Bonjour vgendron
 

alain.pierrephie

XLDnaute Occasionnel
Bonjour

comme le dit @pierrejean en mettant le signe =

@alain.pierrephie bah non. dans ton fichier en cellule AI2, le signe = n'y est pas
et quand on le rajoutte.. le résultat est 445...
Bien vu vgendron, mais sur mon dossier originel il y est bien entendu. J'ai voulu mettre la formule visible et ai fait un copier coller uniquement sur la formule afin de la faire apparaitre.
Ce qui est étrange c'est que le copié coller la formule fonctionne (445) alors que sur mon dossier ça ne marche pas. Nous sommes en plein dans mon souci.
merci a vous vgendron
 

Victor21

XLDnaute Barbatruc
Bonjour à tous
L'erreur ne se reproduit pas dans votre fichier exemple, il nous sera difficile d'en connaître la cause.
Vous pouvez tenter de retrouver la/les cellules en cause en "décortiquant" votre formule à l'aide de "évaluer la formule" en pas à pas.
1631698728229.png
 

alain.pierrephie

XLDnaute Occasionnel
et donc.. on est censé identifier une erreur d'une formule (qui pour nous donne un résultat) sur un fichier que l'on ignore..

c'est un peu le client qui appelle le service téléphone pour dire "'mon téléphone ne marche pas"...
:-D
Je le sais bien mais même des petits dossiers sont refusé car "trop gros". J'ai fait ce que j'ai pu mais vous avez raison dans l'exemple que vous donnez; j'ai jeté une bouteille a la mer.
A l'impossible nul n'est tenu et vous remercie tous en tout cas.
Je reste branché au cas ou qqun aurait une idée.
Merci encore
 

Jocelyn

XLDnaute Barbatruc
re,
Bonjour Victor21 :)

vu ta formule et sans fichier original je pense que ton problème vient de la colonne X qui doit contenir des valeur alpha

tu peux donc essayer de modiifer ta formule de cette façon

VB:
=SOMMEPROD(($V$3:$V$100=AH2)*($B$3:$B$100>=AE2)*($B$3:$B$100<=AF2)*1;$X$3:$X$100)

ou éplucher ta colonne X pour virer les valeur alpha

Cordialement
 

alain.pierrephie

XLDnaute Occasionnel
re,
Bonjour Victor21 :)

vu ta formule et sans fichier original je pense que ton problème vient de la colonne X qui doit contenir des valeur alpha

tu peux donc essayer de modiifer ta formule de cette façon

VB:
=SOMMEPROD(($V$3:$V$100=AH2)*($B$3:$B$100>=AE2)*($B$3:$B$100<=AF2)*1;$X$3:$X$100)

ou éplucher ta colonne X pour virer les valeur alpha

Cordialement
merci Jocelyn je regarde
 

Discussions similaires

Statistiques des forums

Discussions
290 755
Messages
1 910 209
Membres
176 538
dernier inscrit
Charlydebutant
Haut Bas