AvanceRetard des Numéros avant sortie ...

Claude

XLDnaute Occasionnel
Bonjour le Forum !
Très bonne année à tous !

Voici ma question :
Il s’agit de connaître sur un intervalle de 17 tirages, l’état auquel se trouvaient les numéros avant leurs sorties.
Par exemple, pour un nombre de 49 numéros et pour des tirages à 6 numéros, sur un intervalle de 17 tirages nous avons 17x6 =102/49 = 2,08 qu’on arrondi à 2 . Ce qui veut dire que dans un intervalle de 17 tirages un numéro sort en moyenne 2 fois, mais il peut sortir + ou -, l’état des numéros sera ainsi représenté par +, 0 et -
Par exemple, pour les 2 tirages :
N°21 : 3 14 33 34 38 44
N°22 : 5 12 27 32 33 43
L’état de ces 12 numéros sera respectivement représenté comme suit :
N°21 : 0 3 0 1 4 0
N°22 : 0 -2 -1 -1 0 0
Pour ce groupe de 12 numéros, il s’agit de connaître pour chacun d’eux leur état juste avant leurs sorties, soit au tirage N°20
Pour la ligne 21 et pour calculer l’état du N°3, j’applique donc la formule :
=NB.SI(C4:H20;C21)-2 C4 :H20 étant l’intervalle de 17 tirages et C21 le N°3, l’état résultant étant « 0 »
Pour la ligne N°22, pour calculer l’état du N°5, la formule :
=NB.SI(C4:H20;C22)-2 C4 :H20 étant l’intervalle de 17 tirages et C22 le N°5, l’état résultant étant « 0 »
Ainsi de suite pour chaque cellule, j’ai les états recherchés. Mais comment faire, si je veux calculer de 2 en 2 tirages, sur une liste de tirages importante. Il faut une formule à recopier vers le bas !

Ci-joint un fichier que j’ai nommé « avanceretardparpasdedeux» présentant plus explicitement, le travail recherché.

Je suis sur un PC sous XP et j’utilise Excel 97.

PS : Il y a 1 semaine Monique avait très rapidement résolu un problème du même ordre, mais hélas, je n’ai pas su mettre à profit sa formule pour ce nouveau cas !

Avec tous mes remerciements Claude
Mes meilleurs voeux pour 2007
 

Pièces jointes

  • avanceretardparpasdedeux.zip
    6.2 KB · Affichages: 36

JeanMarie

XLDnaute Barbatruc
Re : AvanceRetard des Numéros avant sortie ...

Bonjour Claude

Formule à mettre en J21, et fait un glisser déposer vers la droite et vers le bas
Code:
=NB.SI(DECALER($C20:$H20;-16-MOD(LIGNE()-1;2);0;17);C21)-2

La fonction DECALER permet de déterminer une plage de cellules en fonction, d'une cellule ou d'une plage de référence, et en fonction d'un déplacement vertical (-16-MOD(LIGNE()-1;2)) et horizontal (0) et d'une longueur (17)

@+Jean-Marie
 

Claude

XLDnaute Occasionnel
Re : AvanceRetard des Numéros avant sortie ...

Merci Monique et Jean-Marie !

Le 2 formules fonctionnent parfaitement bien sur l'exemple indiqué.
Par contre, pour un intervalle de tirage plus important de 98 tirages par exemple, il y a des distorsions. La formule de Jean-Marie semble fonctionner à 100%. celle de Monique présente quelques imperfections.
Voici comment j'ai appliqué la formule de Monique :
=NB.SI(INDIRECT("c"&PAIR(LIGNE()-99)&":h"&PAIR(LIGNE()-2));C3989)-12

Celle de Jean-Marie :
=NB.SI(DECALER($C3988:$H3988;-97-MOD(LIGNE()-1;2);0;98);C3989)-12

Y a t'il une erreur quelque part ?!

Merci de votre aide. Amicalement Claude
 

Statistiques des forums

Discussions
298 857
Messages
1 972 333
Membres
203 670
dernier inscrit
Maniearn