XL 2016 association de chiffre + date

MICHAEL

XLDnaute Occasionnel
Bonjour!

en A1 (fonction aujourd'hui)
en A2 (format date): un chiffre de 1 à 31

je souhaiterais associé ce chiffre (A2) avec le n° du mois A1.

Merci de votre aide
 

MICHAEL

XLDnaute Occasionnel
bonjour,
merci de votre proposition.
celle ci fonctionne. Cependant je suis obligé de passer par une troisieme cellule dans laquelle
je rentre le chiffre de 1 à 31.
or, je souhaitais rentrer ce chiffre en A2 simplement.
pensez vous que cela soit possible?
 

Modeste geedee

XLDnaute Barbatruc
bonjour,
merci de votre proposition.
celle ci fonctionne. Cependant je suis obligé de passer par une troisieme cellule dans laquelle
je rentre le chiffre de 1 à 31.
or, je souhaitais rentrer ce chiffre en A2 simplement.
pensez vous que cela soit possible?
=TEXTE(DATE(ANNEE(AUJOURDHUI());MOIS(AUJOURDHUI());A2);"jj/mm")
attention à la cohérence pour nbr maxi de jours selon mois
 

job75

XLDnaute Barbatruc
Bonjour MICHAEL, Modeste geedee,

Fichier joint avec cette macro (clic droit sur l'onglet et Visualiser le code) :
Code:
Private Sub Worksheet_Change(ByVal Target As Range)
Application.EnableEvents = False 'désactive les évènements
If Not IsDate([A1]) Then [A1] = "=TODAY()"
If IsDate([A2] & "/" & Month([A1]) & "/" & Year([A1])) Then
    [A2] = "'" & [A2] & "/" & Month([A1])
Else
    If Not Intersect(Target, [A2]) Is Nothing Then [A2] = ""
End If
Application.EnableEvents = True 'réactive les évènements
End Sub
A+
 

Fichiers joints

job75

XLDnaute Barbatruc
Re,

Dans ce fichier (2) l'entrée en A2 est transformée en date au format jj/mm :
Code:
Private Sub Worksheet_Change(ByVal Target As Range)
Application.EnableEvents = False 'désactive les évènements
If Not IsDate([A1]) Then [A1] = "=TODAY()"
If IsDate([A2].Value2 & "/" & Month([A1]) & "/" & Year([A1])) Then
    [A2] = DateSerial(Year([A1]), Month([A1]), [A2])
Else
    If Not Intersect(Target, [A2]) Is Nothing Then [A2] = ""
End If
Application.EnableEvents = True 'réactive les évènements
End Sub
A+
 

Fichiers joints

Discussions similaires


Haut Bas