Arrondissement

Vincent_BRP

XLDnaute Nouveau
Bonjour,

voici ma question

je dois arrondir les chiffres après la virgule soit à 00 si ceux-ci ce situent entre 0 et 49 et arrondir à ,99 si ceux-ci se trouvent entre 50 et 99

ex : 5,32 doit être 5,00
5,87 doit être 5,99

en tant que tel ce problème ne semble pas si compliqué à résoudre à l'aide de SI et DROITE, cependant une difficulté apparaît lorsqu'on à des chiffres comme 5,70 (le 0 de 70 n'est pas détecté par DROITE)

Merci de m'aider!
 

mapomme

XLDnaute Barbatruc
Supporter XLD
Re : Arrondissement

Bonsoir Vincent_BRP,

Peut-être cette formule:
Code:
=SI(A1-TRONQUE(A1)<0,5;TRONQUE(A1);TRONQUE(A1)+0,99)
 

Vincent_BRP

XLDnaute Nouveau
Re : Arrondissement

Merci beaucoup!
j'avais finalement trouvé celle-ci qui fonctionne aussi:
=SI(ARRONDI(H2;0)<H2;GAUCHE(H2;CHERCHE(".";H2))+0;GAUCHE(H2;CHERCHE(".";H2))+0.99)

mais la tienne semble plus simple, merci!
 

hoerwind

XLDnaute Barbatruc
Re : Arrondissement

Bonjour, salut les autres,

J'avais trouvé celle-ci, petite sœur de celle de Victor :
Code:
=ARRONDI(A1;0)-(MOD(A1;1)>=0,5)/100
 
Démarré par Discussions similaires Forum Réponses Date
J Forum Excel 13
B Forum Excel 6
P Forum Excel 7
J Forum Excel 10
J Forum Excel 4

Discussions similaires


Haut Bas