Algorithme de comparaison

geo909

XLDnaute Nouveau
Kikou all,

Je recherche un algorithme qui me simplifierait grandement la vie. Je n'ai pas les connaissances pour le faire ni même pour savoir si c'est possible :(

J'ai 5 caractères (Code à barre) qui sont être associé à un numéro de programme.
J'ai une série de 141 code à barre
Je reçois de nouveaux code à barre régulièrement

Exemple : Code à barre - N° programme associé

1DT62B1 - 3
2DW32B0 - 21
1DR62B0 - 3
2DU54B1 - 21

Tous les code à barre sont renseignés dans un tableau excel (1 code à barre par ligne)
La colonne 1 pour les codes la colonne 2 pour les n° de programme

Bon but est de trouver un algorithme qui vérifiera tous les 141 codes barre de la feuille excel pour en sortir le résultat suivant (sur la base de l'exemple précédant):
Si le 4ème digit = 6 et que le 5ème digit = 2 c'est que c'est un programme 3
Si le 1er digit = 2 et que le 2ème digit = D c'est que c'est un programme 21

Une fois l’algorithme trouvé je le rentrerais dans un automate pour que, si on lit le code barre, on sache directement le n° de programme

J'espère avoir été plus ou moins clair

Merci de m'avoir lu ;)

PS : Désolé pour la longueur du message mais c'est chaud à expliquer
 

Lean

XLDnaute Junior
Re : Algorithme de comparaison

Bonjour,

Une solution
Formule à entrer dans la colonne 2 et à étirer vers le bas.
Code:
=SI(ET(STXT(A1;4;1)="6";STXT(A1;5;1)="2");3;SI(ET(STXT(A1;1;1)="2";STXT(A1;2;1)="D");21;""))
 
Dernière édition:

Membres actuellement en ligne

Statistiques des forums

Discussions
294 371
Messages
1 938 081
Membres
188 641
dernier inscrit
pcayet