Microsoft 365 Aise Fonction Excel suivant %

XaOE33

XLDnaute Nouveau
Supporter XLD
Bonjour à toutes et tous,

Je sollicite votre aide une nouvelle fois pour m'aider à compléter un tableau qui me permettra de calculer des primes mensuelles et trimestrielles en fonction d'un CA réalisé.

Pour le calcule des primes mensuelles, l'ai besoin qu'Excel applique le barème en fonction d'un pour % connu.
Dans mon exemple, pour le mois de janvier l'objectif a été dépassé de 65% (J12) donc Excel doit appliquer le barème de 8% (L7) au CA réalisé de janvier 2021 (E12)
d'avril l'objectif à été dépassé de 14% (J15) donc Excel doit appliquer le barème de 2% (L4) au CA réalisé du mois d'avril 2021 (E15)

NB si le CA mensuel réalisé est inférieur au CA objectif (H11) alors prime = 0€

J'espère avoir été assez clair dans les explications et reste bien naturellement à votre disposition si besoin,

un Grand merci d'avance pour vos réponses,

Bonne journée à tous
Xavier
 

Pièces jointes

  • Simulation OE.xlsx
    35.4 KB · Affichages: 14
Solution
RE

Un minimum d'effort de ta part et tu aurais vu que les 8% étaient multipliés par I12 au lieu de E12 : cela t'aurait pris moins de temps de faire cette modif que de poster...

donc
=SI(E12<>0;RECHERCHEV(J12;$I$3:$L$7;4)*E12;0)
eu lieu de
=SI(E12<>0;RECHERCHEV(J12;$I$3:$L$7;4)*I12;0)

à étirer en dessous

XaOE33

XLDnaute Nouveau
Supporter XLD
Merci pour ta réponse, mais je me suis probablement mal exprimé, car les résultats ne sont pas ceux attendus

En cellule K12, le résultat correct est : 6585.08€
Je m'explique :
- Le CA objectif (ici 50000€ en H11) est atteint et même dépassé
- Donc CA réalisé de janvier 2021 * 8% (Car progression > 41%)

J'espère avoir été plus clair cette fois ci

Merci
 

chris

XLDnaute Barbatruc
RE

Un minimum d'effort de ta part et tu aurais vu que les 8% étaient multipliés par I12 au lieu de E12 : cela t'aurait pris moins de temps de faire cette modif que de poster...

donc
=SI(E12<>0;RECHERCHEV(J12;$I$3:$L$7;4)*E12;0)
eu lieu de
=SI(E12<>0;RECHERCHEV(J12;$I$3:$L$7;4)*I12;0)

à étirer en dessous
 
Haut Bas